OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Template changes not being reflected

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Template changes not being reflected

Postby jturner » Tue Mar 25, 2014 2:00 pm

I've been trying to edit the templates for my OCS installation and it seems that none of the changes are being reflected on the actual site. For instance, I added an <h3> tag to the /templates/about/index.php and the change does not seem to appear on the site, even after clearing my cache. Has anyone else experienced this issue?
jturner
 
Posts: 3
Joined: Tue Mar 11, 2014 1:21 pm

Re: Template changes not being reflected

Postby asmecher » Tue Mar 25, 2014 2:55 pm

Hi jturner,

This probably indicates that your file permissions are too restrictive in the templates/t_compile directory. PHP scripts need to be able to administer content in that directory. The required file permissions are described in docs/README.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8426
Joined: Wed Aug 10, 2005 12:56 pm

Re: Template changes not being reflected

Postby jturner » Mon Mar 31, 2014 1:05 pm

Mr. Smecher,

Thanks for the quick reply. I checked and the templates/t_compile directory doesn't exist on my installation. Does this point to a bad installation or do I need to create the directory myself and modify its permissions?
jturner
 
Posts: 3
Joined: Tue Mar 11, 2014 1:21 pm

Re: Template changes not being reflected

Postby asmecher » Mon Mar 31, 2014 1:53 pm

Hi jturner,

Sorry, that should be cache/t_compile, not templates/t_compile.

That directory is included in the OCS .tar.gz file, but it's empty when shipped. Some programs e.g. WinZip will not by default create empty directories. You should be OK to create the directory yourself, if it doesn't exist; the contents should be created automatically.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8426
Joined: Wed Aug 10, 2005 12:56 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 6 guests