OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Mail Problem

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Mail Problem

Postby abhiram » Tue Dec 12, 2006 4:07 am

Hi Alec,
I couldnot send mails to reviewers using OJS.I wants to know how to configure mail in ojs

Regards
Abhiram .H
abhiram
 
Posts: 30
Joined: Thu Aug 03, 2006 7:31 am
Location: India

Postby asmecher » Tue Dec 12, 2006 12:39 pm

Hi Abhiram,

The relevant settings are in OJS's config.inc.php configuration file. By default, OJS uses the local MTA or SMTP server, depending on your platform; you may need to configure the [smtp] section of your configuration file before mail can be successfully sent.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 9208
Joined: Wed Aug 10, 2005 12:56 pm

Mail not working

Postby abhiram » Fri Dec 15, 2006 10:50 pm

Hi Alec ,
As you mentioned , I referred the config.inc.php file . currently I am acting as the editor and my mail id is abhiramh@gmail.com . I wants to inform reviewers to do the review process by sending mails via ojs . but that functionality is not working . The SMTP section in my Config.inc.php file is given below

/////////////////////////////////////////////////////////
Use SMTP for sending mail instead of mail()
; smtp = On

; SMTP server settings
; smtp_server = mail.example.com
; smtp_port = 25

; Enable SMTP authentication
; Supported mechanisms: PLAIN, LOGIN, CRAM-MD5, and DIGEST-MD5
; smtp_auth = PLAIN
; smtp_username = username
; smtp_password = password

; Allow envelope sender to be specified
; (may not be possible with some server configurations)
; allow_envelope_sender = Off

; Enable attachments in the various "Send Email" pages.
; (Disabling here will not disable attachments on features that
; require them, e.g. attachment-based reviews)
enable_attachments = On

////////////////////////////////////////////////////////////
Expecting a detailed solution from you

Thanks and Regards
Abhiram .H


asmecher wrote:Hi Abhiram,

The relevant settings are in OJS's config.inc.php configuration file. By default, OJS uses the local MTA or SMTP server, depending on your platform; you may need to configure the [smtp] section of your configuration file before mail can be successfully sent.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
abhiram
 
Posts: 30
Joined: Thu Aug 03, 2006 7:31 am
Location: India

Postby asmecher » Sat Dec 16, 2006 10:06 am

Hi Abhiram,

The settings you need to use will depend on your server configuration, but I suspect that you'll need to change the smtp_server setting to the name of your SMTP server and turn SMTP delivery on by un-commenting the "smtp = On" directive. (Note that the semicolon at the start of each line tells OJS to ignore the line, so you'll need to remove these semicolons for the lines you change.)

You may need to ask your server admin for the appropriate settings to use.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 9208
Joined: Wed Aug 10, 2005 12:56 pm

Mail not working

Postby abhiram » Tue Dec 19, 2006 11:31 pm

Hi Alec,
I couldnt fix the mail problem that I earlier posted to you. Can u show me the
SMTP section of a mail configured config.inc.php file. I hope that will be really useful for me
Also , One problem that I noted was send mail is not working in my server
When I activate send mail, some errors occured . Errors are as follows
**********************************************
sendmail failed. The error was: Starting sendmail: 451 4.0.0 /etc/mail/sendmail.cf: line 91: fileclass: cannot open '/etc/mail/local-host-names': World writable directory

451 4.0.0 /etc/mail/sendmail.cf: line 588: fileclass: cannot open '/etc/mail/trusted-users': World writable directory

[FAILED]
**********************************************

Looking forward your reply

Thanks and Regards
Abhiram .H






asmecher wrote:Hi Abhiram,

The settings you need to use will depend on your server configuration, but I suspect that you'll need to change the smtp_server setting to the name of your SMTP server and turn SMTP delivery on by un-commenting the "smtp = On" directive. (Note that the semicolon at the start of each line tells OJS to ignore the line, so you'll need to remove these semicolons for the lines you change.)

You may need to ask your server admin for the appropriate settings to use.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
abhiram
 
Posts: 30
Joined: Thu Aug 03, 2006 7:31 am
Location: India

Postby asmecher » Wed Dec 20, 2006 1:22 pm

Hi Abhiram,

If you're using SMTP, the following section is an example. (Replace "YOUR_SMTP_SERVER_NAME_HERE" with the proper server name.)
Code: Select all
;;;;;;;;;;;;;;;;;;
; Email Settings ;
;;;;;;;;;;;;;;;;;;

[email]

; Use SMTP for sending mail instead of mail()
smtp = On

; SMTP server settings
smtp_server = YOUR_SMTP_SERVER_NAME_HERE
smtp_port = 25

; Enable SMTP authentication
; Supported mechanisms: PLAIN, LOGIN, CRAM-MD5, and DIGEST-MD5
; smtp_auth = PLAIN
; smtp_username =
; smtp_password =

; Allow envelope sender to be specified
; (may not be possible with some server configurations)
allow_envelope_sender = On

; Enable attachments in the various "Send Email" pages.
; (Disabling here will not disable attachments on features that
; require them, e.g. attachment-based reviews)
enable_attachments = On
The sendmail error message is probably the reason that mail sending isn't working. The following message:
The error was: Starting sendmail: 451 4.0.0 /etc/mail/sendmail.cf: line 91: fileclass: cannot open '/etc/mail/local-host-names': World writable directory
...indicates that Sendmail is not running because it's detected an insecure mail configuration. Correct this and you may find that OJS is able to send mail properly.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 9208
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests