OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



2.4.3 upgrade not taking

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

2.4.3 upgrade not taking

Postby phoebusmedia » Wed Mar 19, 2014 11:37 am

Hello,
I just shelled into my hosting account and ran the 2.4.2 to 2.4.3 patch and nothing seems to have changed with my OJS system. When I try to run the patch again it recognizes that it already has patched the system so I know the files deployed. But when I go to the webpages, there is no difference. When I log in, it still says I am running 2.4.2. and I am not prompted for anything nor do I get any "on-screen installation instructions". What am I missing or doing wrong? Any suggestions are appreciated.
Thanks,
John
phoebusmedia
 
Posts: 3
Joined: Wed Mar 19, 2014 11:31 am

Re: 2.4.3 upgrade not taking

Postby asmecher » Wed Mar 19, 2014 11:44 am

Hi John,

Please review the instructions in docs/UPGRADE.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm

Re: 2.4.3 upgrade not taking

Postby phoebusmedia » Wed Mar 19, 2014 12:00 pm

Hi Alec,
I did. I ran the command php tools/upgrade.php upgrade. No difference. I received no error, but nothing changed on my OJS installation. Still says I have 2.4.2. I also tried the web update, changing the config to have installed=off. I get the upgrade page and when I click upgrade it goes to index.php/index/install/installUpgrade and I just get a blank screen. Last august I upgraded 2.4.1. to 2.4.2 without incident. So I am confused on why this patch is not working. Any suggestions as to how to proceed?
Thanks,
John
phoebusmedia
 
Posts: 3
Joined: Wed Mar 19, 2014 11:31 am

Re: 2.4.3 upgrade not taking

Postby asmecher » Wed Mar 19, 2014 12:19 pm

Hi John,

What do you get for the output of the upgrade script?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm

Re: 2.4.3 upgrade not taking

Postby phoebusmedia » Wed Mar 19, 2014 12:25 pm

Hi Alec,

If you mean the patch, it ran down the list of files it was patching. When I tried the patch a second time, it prompted me for each file saying it was already patched. If you mean the database using php upgrade, nothing. It just returned to the prompt waiting for input. If you mean the web upgrade, it give me the install screen. I clicked the upgrade link. On the next page there was the upgrade button which i clicked and it then gave me the blank screen at the URL I posted above.

John
phoebusmedia
 
Posts: 3
Joined: Wed Mar 19, 2014 11:31 am

Re: 2.4.3 upgrade not taking

Postby asmecher » Wed Mar 19, 2014 12:33 pm

Hi John,

By upgrade script I mean tools/upgrade.php; this is equivalent to the web upgrade but will be easier to debug. If it's just returning you to the command line, it's not working properly. The most common cause of this is that your php.ini is missing a MySQL module; this can happen even if your web site is working properly because some servers have a separate php.ini for the command line as opposed to the web server.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests