OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



clearPageContext Path_info problem

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

clearPageContext Path_info problem

Postby pilone » Mon Mar 17, 2014 8:46 am

Hello!

I have a problem with blank pages in the administration menu off OCS. A lot of the links in the administration panel add the option ?clearPageContext=1 to the URL. When this option is set, all I get is a blank page. The page loads normally when I delete this part of the URL or if I change it to /clearPageContext. I suspected the second option might work as I have Path Info enabled. I suspect it is just ignored though, because the blank pages do also occur when I use normal URLs (?option1=value&option2=value ...) with clearPathInfo=1 ...

there are no error messages, i just see hundreds of deprecation warnings. I didn't find something that helped me here either.

At the moment, my workaround would be to manually alter all the URLs in the core-files be deleting the clearPageContext-part things like: "{url op="schedConfs" clearPageContext=1}"

Best Regards,
Stephan
pilone
 
Posts: 11
Joined: Wed Dec 19, 2012 3:11 am

Re: clearPageContext Path_info problem

Postby pilone » Tue Mar 18, 2014 4:31 am

Hi,

Issue is fixed. After some searching and being angry, I finally checked the php error logs and found that the problem was the session_is_registered()-function used in /lib/pkp/classes/session/Session.inc.php on line 64. This function has been removed in PHP 5.4 and we are running 5.5 on our server.

Related Bug Report and Patch: http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=7544

Cheers,
Stephan
pilone
 
Posts: 11
Joined: Wed Dec 19, 2012 3:11 am


Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 0 guests