OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Images in HTML full text

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Images in HTML full text

Postby wawax » Thu Mar 06, 2014 11:56 am

Hello!
I read forum threads on this subject, but I still can't make it work.
In Editing/Layout I send Galley file in HTML format. HTML file refers to: <img src="Image_001.jpg"/>
Then I add Supp. file in JPG format (Image_001.jpg).

I can see it uploaded in folder .../files/journals/1/articles/7/supp/7-31-1-SP.jpg. I can also download it from Editor panel.

Effect: when I show article, link refers stil to Image_001.jpg.
What I do wrong?
wawax
 
Posts: 2
Joined: Thu Mar 06, 2014 11:51 am

Re: Images in HTML full text

Postby asmecher » Thu Mar 06, 2014 12:19 pm

Hi wawax,

Images shouldn't be uploaded as supplementary files; they should be uploaded in the HTML galley's "Edit" page. If you don't see an option to upload images there, your system probably isn't detecting HTML files properly; in that case, search the forum for "MIME type" for some related threads.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9090
Joined: Wed Aug 10, 2005 12:56 pm

Re: Images in HTML full text

Postby wawax » Thu Mar 06, 2014 12:23 pm

Now it works great. Thank you very much!
wawax
 
Posts: 2
Joined: Thu Mar 06, 2014 11:51 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Tiziano, Yahoo [Bot] and 1 guest