OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Unable to choose language during QuickSubmit

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Unable to choose language during QuickSubmit

Postby geirrosset » Tue Feb 18, 2014 2:45 am

Hello

I am unable to choose language during QuickSubmit, the pull down menu is blank, which means I cannot submit articles at all. Can anyone help? Can I turn this off? At the bottom there is a field for language code so what is the point of the pull down menu?

Best regards
Geir Rosset
Oslo
Norway
geirrosset
 
Posts: 38
Joined: Tue Aug 30, 2011 1:57 am

Re: Unable to choose language during QuickSubmit

Postby asmecher » Tue Feb 18, 2014 8:56 am

Hi Geir,

What version of OJS are you using?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Re: Unable to choose language during QuickSubmit

Postby geirrosset » Wed Feb 19, 2014 2:12 am

I am using a clean install of 2.4.3

Brgds
Geir
geirrosset
 
Posts: 38
Joined: Tue Aug 30, 2011 1:57 am

Re: Unable to choose language during QuickSubmit

Postby asmecher » Thu Feb 20, 2014 4:16 pm

Hi Geir,

In the Journal Manager's "Languages" page, what do you have for enabled languages under the "Submissions" header?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Re: Unable to choose language during QuickSubmit

Postby geirrosset » Fri Feb 21, 2014 1:37 am

The primary language drop down is empty, like under submissions, and there are no languages listed below it although there are two rows of check boxes. Something is not right.

grab.jpg
grab.jpg (138.15 KiB) Viewed 561 times
geirrosset
 
Posts: 38
Joined: Tue Aug 30, 2011 1:57 am

Re: Unable to choose language during QuickSubmit

Postby asmecher » Fri Feb 21, 2014 9:45 am

Hi Geir,

Hmm, that does look strange. Can you move up to the Site Administrator's languages page and check what the settings are there?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Re: Unable to choose language during QuickSubmit

Postby geirrosset » Mon Feb 24, 2014 1:47 am

Looks very similar to the other screenshot...

Skjermbilde-2014-02-24-kl.-09.45.38.jpg
Skjermbilde-2014-02-24-kl.-09.45.38.jpg (94.35 KiB) Viewed 540 times
geirrosset
 
Posts: 38
Joined: Tue Aug 30, 2011 1:57 am

Re: Unable to choose language during QuickSubmit

Postby asmecher » Mon Feb 24, 2014 9:13 am

Hi Geir,

Yes, there's definitely something wrong with your installation. Have you made any modifications to it? (In particular the registry/locales.xml file?) What is your character set configuration in config.inc.php?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Re: Unable to choose language during QuickSubmit

Postby geirrosset » Tue Feb 25, 2014 1:38 am

From config:

[i18n]

; Default locale
locale = en_US

; Client output/input character set
client_charset = utf-8

The only modifications we made was to change the message in locale.xml that appears when you click register (as we do not accept user registrations and want potential contributors to contact us via email in stead. That message is correctly terminated using </message>

Can we reload each locale (Norwegian and English)? I know we'll loose the message we altered, but that takes about 10 seconds to redo...
geirrosset
 
Posts: 38
Joined: Tue Aug 30, 2011 1:57 am

Re: Unable to choose language during QuickSubmit

Postby geirrosset » Tue Feb 25, 2014 2:18 am

Under Quicksubmit it states: This journal accepts submissions in several languages. Choose the primary language of the submission from the pulldown below.

Where does it say that the journal accepts submissions in several languages? Under languages I have only one check mark under submissions.

Geir
geirrosset
 
Posts: 38
Joined: Tue Aug 30, 2011 1:57 am

Re: Unable to choose language during QuickSubmit

Postby asmecher » Tue Feb 25, 2014 9:03 am

Hi Geir,

The problem appears to be that OJS is having trouble parsing the locale list, registry/locales.xml, and that's having numerous knock-on effects. Can you try flushing your data cache (by deleting all .php files in cache/ and then verifying that they're all gone; then try the system and verify that they're getting re-created)? Also double-check registry/locales.xml to make sure that it's valid.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Re: Unable to choose language during QuickSubmit

Postby geirrosset » Wed Feb 26, 2014 2:29 am

That fixed it. Now the pull down menu on the quicksubmit page is gone. And the language names are visible in the other pull down menus.

Thank you! Now to catch up on one week of submissions :)
geirrosset
 
Posts: 38
Joined: Tue Aug 30, 2011 1:57 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests