OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Simple search form returns 404 error

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Simple search form returns 404 error

Postby newbies » Sat Feb 08, 2014 10:24 pm

It is weird that the simple search form on the home page (side block) does not work and returns a 404 error.

The form has this code: <form id="simpleSearchForm" action="http://www.mydomain.org/index.php/jbm/search/results" method="post">

The result page has this url: http://www.mydomain.org/index.php/index/search/results

I am using 2.4.2

I search this forum and did not find anyone else reporting this error.
newbies
 
Posts: 87
Joined: Sat Feb 23, 2013 9:15 pm

Re: Simple search form returns 404 error

Postby JasonNugent » Mon Feb 10, 2014 7:42 am

Hi newbies,

I just installed a 2.4.2 OJS instance to test this and I can't reproduce the problem. If you want, you can PM me your real URL so I can look at it.

Regards
Jason
JasonNugent
Site Admin
 
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: Simple search form returns 404 error

Postby newbies » Mon Feb 10, 2014 9:22 am

Hi Jason,

Thank you so much for replying. I've pm-ed you.
newbies
 
Posts: 87
Joined: Sat Feb 23, 2013 9:15 pm

Re: Simple search form returns 404 error

Postby JasonNugent » Mon Feb 10, 2014 10:42 am

Hi newbies,

It looks like you may have merged in a previous version of OJS with some new code? The reason why your search is broken is because the op for the search result page changed from 'results' to 'search' in this commit:

https://github.com/pkp/ojs/commit/85133 ... c0e#diff-7

Which happened two years ago. It looks like you may still have an old version of the navigation block plugin, possibly because you have made some theme customizations?

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: Simple search form returns 404 error

Postby newbies » Mon Feb 10, 2014 12:40 pm

What shall I do? upgrade the navigation block plugin or simple change the form action to op=search?

Thank you!
newbies
 
Posts: 87
Joined: Sat Feb 23, 2013 9:15 pm

Re: Simple search form returns 404 error

Postby JasonNugent » Mon Feb 10, 2014 3:00 pm

Hi newbies,

Changing the form op will fix your immediate issue but I would then ask the question "What else didn't make it into the last OJS upgrade" when you merged in your previous version of OJS with the current one.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: Simple search form returns 404 error

Postby newbies » Mon Feb 10, 2014 5:09 pm

Hi Jason,

change op=results to op=search solved the problem.

the current installation was a 2.4.2 and not upgraded from a earlier version. Are some patches missing?
newbies
 
Posts: 87
Joined: Sat Feb 23, 2013 9:15 pm

Re: Simple search form returns 404 error

Postby JasonNugent » Tue Feb 11, 2014 7:49 am

Hi newbies,

The downloaded tarball would have included everything committed to the code repositories at the time the release was created. Have you applied all of the recommended patches for 2.4.2?

http://pkp.sfu.ca/wiki/index.php?title= ... ed_Patches

We've also released 2.4.3 now, as well as some recommended patches for that.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: Simple search form returns 404 error

Postby newbies » Tue Feb 11, 2014 9:33 am

I applied some patches for 2.4.2, but not for all.

Should I upgrade to 2.4.3 or wait for 3.0? My templates have been extensively customized I am afraid upgrade to 2.4.3 would cause problems.
newbies
 
Posts: 87
Joined: Sat Feb 23, 2013 9:15 pm

Re: Simple search form returns 404 error

Postby JasonNugent » Tue Feb 11, 2014 10:27 am

Hi newbies,

3.0 will be baking for a while, and has a completely redesigned layout based on our previously released Open Monograph Press. If you upgrade to either, you'll be doing some code merging, but the pain will be worse with 3.0, I fear.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests