OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Active Review Count INCORRECT

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Active Review Count INCORRECT

Postby lizlcjp » Thu Dec 26, 2013 11:39 am

HELP!

I have several reviewers who are listed as having a handful of active reviews. When I log in to their accounts (using Journal Management tools), I see that they have no reviews active, or the active number does not correspond to the active number I see when attempting to assign them to review a manuscript.

Any tips?
lizlcjp
 
Posts: 2
Joined: Thu Jan 17, 2013 10:02 am

Re: Active Review Count INCORRECT

Postby asmecher » Thu Dec 26, 2013 2:27 pm

Hi lizlcjp,

What version of OJS are you using?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8307
Joined: Wed Aug 10, 2005 12:56 pm

Re: Active Review Count INCORRECT

Postby memoemg » Wed Feb 05, 2014 9:16 am

Hi Alec we are having the same problem with the active review counter.

We are using 2.4.3

Guillermo
memoemg
 
Posts: 11
Joined: Thu Sep 05, 2013 2:35 pm

Re: Active Review Count INCORRECT

Postby aleskl » Fri Feb 14, 2014 5:51 am

Hi!

I have this problem too. But in both directions - the reviewer on the reviewer selection page shows 0 active reviews, but when I log into their account I can see they have active reviews in progress OR the active count is more than zero, but the reviewer actually doesn't have any active reviews. So the ACTIVE count shows something completely different from the actual active reviews.

I've checked for the http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=8407, but this is fixed in the 2.4.3 version that we are using.

Also the DONE column contains wrong numbers, eg. for a reviewer with 5 archived reviews the Done column shows 3. Actually, for that particular reviewer, the number of papers reviewed is 3, but for two papers the reviewer was involved in two rounds, and for the last paper the review was not submitted.

When I checked other reviewers which have an active count of 1 in the reviewers table it turned out that none of them have an active review in progress, but they have an unfinished (unsubmitted) review in the Archive section. But these should not count in the Active number of reviews.

Then, for another random reviewer, all the data is correct. DONE column shows 8 reviews, which is the actual number of reviews submitted, but three of them were for the second round, so the paper count is only 5 (in contrast to the reviewer above, where the DONE count apparently showed number of papers). Plus, this random reviewer has one unfinished review in the Archive section, but in this case the ACTIVE count shows 0, which is correct, because there are no active reviews in progress.

I have not checked all the reviewers, but for a few checked it seems that the counts are still miscalculated. I'll try to check the database for this to see if I can deduce something from the original values, but so much for now... :?

Regards,
Ales
aleskl
 
Posts: 96
Joined: Mon Apr 11, 2011 7:08 am

Re: Active Review Count INCORRECT

Postby aleskl » Sat Feb 15, 2014 5:06 am

To add, the problem of active count is also with the Layout editors. In our case we have two layout editors, both have a few papers assigned at the moment, but the active count says 0 for both (in the Editors page for selection of layout editor). The same with Copyeditors - we have one, and the active count says 1, however the copyeditor in fact doesn't have any active papers (and 3 in archive).

I tried to tweak classes/submission/sectionEditor/SectionEditorSubmissionDAO.inc.php (that was the problem file in bug 8407). If I remove the NOT check for a.status (a.status != '.STATUS_QUEUED.' AND) the function getReviewerStatistics returns correct count of active reviews. The corrected code is below:

Code: Select all
      // Get completion status
      $result =& $this->retrieve(
         'SELECT r.reviewer_id, COUNT(*) AS incomplete
         FROM    review_assignments r,
            articles a
         WHERE   r.submission_id = a.article_id AND
            r.date_notified IS NOT NULL AND
            r.date_completed IS NULL AND
            r.cancelled = 0 AND
            r.declined = 0 AND
            a.status = '.STATUS_QUEUED.' AND
            a.journal_id = ?
         GROUP BY r.reviewer_id',
         (int) $journalId
      );

But something is still strange, the sorting of table with reviewers doesn't work for the ACTIVE column. The link for sorting is javascript:sortSearch('active','2'), which apparently takes different data for sorting than the actual values that are displayed. Actually, sorting works strange for other columns also - the values get sorted and generally they are distributed from low to high or around, but not exactly, some values end up in wrong places. Just as if the sorting would finish too early?

Regards,
Ales
aleskl
 
Posts: 96
Joined: Mon Apr 11, 2011 7:08 am

Re: Active Review Count INCORRECT

Postby asmecher » Thu Apr 24, 2014 9:20 am

Hi aleskl,

Would you be willing to provide me with a (suitably anonymized) copy of your database along with the user IDs of the users who are seeing the wrong counts? If so, please PM or email me.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8307
Joined: Wed Aug 10, 2005 12:56 pm

Re: Active Review Count INCORRECT

Postby maguero » Tue May 06, 2014 12:08 pm

In version 2.4.2.0 we have the same problem. May be it is counting as active the rejected reviews. Can it be possible?

Regards,
Martín
maguero
 
Posts: 1
Joined: Tue May 06, 2014 11:56 am

Re: Active Review Count INCORRECT

Postby asmecher » Tue May 06, 2014 1:21 pm

Hi Martín,

Same offer as above -- if you're willing to provide a copy of a DB that demonstrates the problem, please let me know.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8307
Joined: Wed Aug 10, 2005 12:56 pm

Re: Active Review Count INCORRECT

Postby memoemg » Mon May 19, 2014 11:59 am

Hi Alec, we have the same problem, but our DB is about 240 MB. Do you need the whole script or just some specific tables. Thank you.

Guillermo
memoemg
 
Posts: 11
Joined: Thu Sep 05, 2013 2:35 pm

Re: Active Review Count INCORRECT

Postby asmecher » Tue May 20, 2014 2:30 pm

Hi memoemg,

User aleskl provided me with his DB, but I couldn't reproduce the behavior locally. Can you compress your DB (e.g. using gzip or zip)? Unfortunately I'll need the whole thing -- though to reduce its size, you can truncate some of the search index tables -- article_search_keyword_list, article_search_object_keywords, article_search_objects.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8307
Joined: Wed Aug 10, 2005 12:56 pm

Re: Active Review Count INCORRECT

Postby asmecher » Wed May 21, 2014 12:40 pm

Hi all,

With Ales' help I've managed to duplicate the problem locally; I've sent him a patch for testing. If anyone else is willing to give it a try, the feedback would be welcome; details and patch at bug #8772.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8307
Joined: Wed Aug 10, 2005 12:56 pm

Re: Active Review Count INCORRECT

Postby aleskl » Tue May 27, 2014 5:05 am

I've applied the patch that Alec prepared and the editor now sees correct counts for reviewers, layout- and copyeditors. I've checked around and everything seems to work.

THANK YOU!!!
Ales
aleskl
 
Posts: 96
Joined: Mon Apr 11, 2011 7:08 am

Re: Active Review Count INCORRECT

Postby asmecher » Tue May 27, 2014 7:44 am

Hi Ales,

Thanks for confirming! This will be released with OJS 2.4.5.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8307
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 4 guests