OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problem with TURKISH LOCALE (OJS 2.4.3)

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Problem with TURKISH LOCALE (OJS 2.4.3)

Postby pashayev » Fri Jan 31, 2014 4:13 pm

Hello I have installed OJS 2.4.3 both on my PC localhost and on 2 webhosts, on my localhost when I install Turkish language and switch primary language to Turkish everyhing ok , it's perfectly swtiched. When I install Turkish in OJS on one of my webhost (doesn't matter) it istalled but when I switch to primary locale to Turkish I get the white page with such errors (Fatal error: Call to undefined method Request::isPathInfoEnabled() in /home/switazco/public_html/ojsdemo/lib/pkp/classes/core/PKPRouter.inc.php on line 151

Fatal error: Call to undefined method Session::getUserId() in /home/switazco/public_html/ojsdemo/lib/pkp/classes/session/SessionDAO.inc.php on line 106
) please help, after that I even cannot establish system and on any other pages of OJS I only see the page with this error. Please help.

P.S. For other languages it's ok, only for Turkish I face this problem :( Please help
pashayev
 
Posts: 3
Joined: Fri Jan 31, 2014 3:51 pm

Re: Problem with TURKISH LOCALE (OJS 2.4.3)

Postby asmecher » Fri Jan 31, 2014 4:44 pm

Hi pashayev,

Have a look at the work-around suggested in this thread.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8869
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problem with TURKISH LOCALE (OJS 2.4.3)

Postby pashayev » Fri Jan 31, 2014 5:16 pm

Ohh thank you very much this is really solved my problem )

Thank you Alec Smecher

Sincerely Huseyn Pashayev.
pashayev
 
Posts: 3
Joined: Fri Jan 31, 2014 3:51 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests