OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



DB error during migration OJS from 2.3.5 to 2.4.2

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

DB error during migration OJS from 2.3.5 to 2.4.2

Postby viat » Tue Jan 28, 2014 3:12 am

We are upgrading the OJS from 2.3.5 to 2.4.2 using full install.

We’ve made backup of a database using PHPMyadmin.

We've unpacked all the folders of 2.4.2 in the ojs installation directory and updated the config.inc.php with the same credentials/settings as the previous version 2.3.5. (except the path for files).
We’ve copied journal files into new directory,
Then set the installed=off mode to go through php mode and clicked "upgrade open journal system". We’ve got the message
"A database error has occurred: Incorrect table definition; there can be only one auto column and it must be defined as a key."

We’ve tried to drop and import the database again and upgrade again. But we’ve got the same error.


PHP version 5.4.14
MySQL version 5.6.11

We are looking for tips and help.

Thanks, Viat
viat
 
Posts: 8
Joined: Tue Jan 28, 2014 2:31 am

Re: DB error during migration OJS from 2.3.5 to 2.4.2

Postby asmecher » Tue Jan 28, 2014 5:22 am

Hi Viat,

Can you try running the upgrade again, this time with the "debug" option on in config.inc.php? This should dump all database queries to the browser, and the last query should be the problem one. If you post it here, I can debug further.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Re: DB error during migration OJS from 2.3.5 to 2.4.2

Postby viat » Tue Jan 28, 2014 6:23 am

Hi Alec,

Log file has been attached

/Regards
Viat
Attachments
footter_log.doc
(80 KiB) Downloaded 17 times
OJS from 2.3.5 to 2.4.2_mysql_error.txt
(31.09 KiB) Downloaded 18 times
viat
 
Posts: 8
Joined: Tue Jan 28, 2014 2:31 am

Re: DB error during migration OJS from 2.3.5 to 2.4.2

Postby asmecher » Tue Jan 28, 2014 6:27 am

Hi Viat,

Neither of these appear to be the log resulting from the "debug" option in config.inc.php -- and the footer debugger shouldn't even be present in the new version; is it possible that there is some old code mixed in with the new?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Re: DB error during migration OJS from 2.3.5 to 2.4.2

Postby viat » Tue Jan 28, 2014 9:31 am

Hi Alec,

1.Debug options are on in the config.inc.php.

2. I’ve attached the current file.

3. During previous run of upgrade in this file was
; Display execution stats in the footer
show_stats = On
4. All the files in the directory asnepb_24mg_235_hoster are from the release 2.4.2 .

/Regards, Viat
Attachments
config_inc_php.txt
(13.95 KiB) Downloaded 18 times
viat
 
Posts: 8
Joined: Tue Jan 28, 2014 2:31 am

Re: DB error during migration OJS from 2.3.5 to 2.4.2

Postby asmecher » Tue Jan 28, 2014 9:35 am

Hi Viat,

When you attempt to run the upgrade with the "debug" option turned on, what do you get in your browser?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Re: DB error during migration OJS from 2.3.5 to 2.4.2

Postby viat » Tue Jan 28, 2014 9:46 am

Hi Alec,

When I attempt to run the upgrade with the "debug" option turned on, what do you get in your browser,
I've got nothing, except a message "During installation DB error: Incorrect table definition; there can be only one auto column and it must be defined as a key

Regards,Viat
viat
 
Posts: 8
Joined: Tue Jan 28, 2014 2:31 am

Re: DB error during migration OJS from 2.3.5 to 2.4.2

Postby asmecher » Tue Jan 28, 2014 10:16 am

Hi Viat,

Would it be possible for you to try upgrading via the command-line rather than via the web interface?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: davidjb and 1 guest