OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Incorrect archive_id given while updating records

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
Developer Resources:

Git: You can access our public Git Repository here. Comprehensive Git usage instructions are available on the wiki.

Bugzilla: You can access our Bugzilla report tracker here.

Search: You can use our Google Custom Search to search across our main website, the support forum, and Bugzilla.

Questions and discussion are welcome.

Incorrect archive_id given while updating records

Postby singhkarki » Mon Jan 27, 2014 11:07 pm

hello Sir,
I have harvested a repository with archive_id =20 ,the records are fine. Later i harvested another repository with archive_id =21, the logs for the harvest are as follows:
UPDATE records
SET
archive_id = '20',
schema_plugin_id = '1',
identifier = 'KOHA-OAI-TEST:9036',
datestamp = null,
what happened was ,the archive previously harvested got incorrect data after i harvested second archive.
How can i resolve this error so that during harvesting of second archive i get the following logs:
UPDATE records
SET
archive_id = '21',


Please suggest ,
thanks and regards,

Vijay
Last edited by singhkarki on Tue Jan 28, 2014 10:09 am, edited 1 time in total.
singhkarki
 
Posts: 41
Joined: Fri Nov 29, 2013 3:28 pm

Re: Incorrect archive_id given while updating records

Postby asmecher » Tue Jan 28, 2014 5:21 am

Hi Vijay,

I suspect this is still related to archives serving the same record identifiers. If you solve that problem and re-harvest all of your archives, this should no longer happen.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8840
Joined: Wed Aug 10, 2005 12:56 pm


Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: No registered users and 2 guests