OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



PHP 5.4 upgrade: from OJS 2.2.4 to 2.4.3

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

PHP 5.4 upgrade: from OJS 2.2.4 to 2.4.3

Postby nahrizuladib » Sat Jan 18, 2014 7:31 am

hi

i have been procrastinating to upgrade since 2.2.4 because my installation works fine; and suddenly my webhost upgraded to PHP 5.4, and my OJS is not working anymore. i've read the forums, and understood that the safest/best bet would be to upgrade, instead of applying patches.

so my (rather noob, my apologies) question is: would 'upgrading' entails just replacing all the php files? do i have to do anything else? will the mySQL database be upgraded automatically?

thanks
nahrizuladib
 
Posts: 19
Joined: Sat Aug 11, 2007 5:10 pm

Re: PHP 5.4 upgrade: from OJS 2.2.4 to 2.4.3

Postby JasonNugent » Sat Jan 18, 2014 10:19 am

Hi nahrizuladib,

No, you'll also need to upgrade the database. There is a file called UPGRADE included with your OJS installation, in the docs/ directory. It contains the instructions for doing so.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 891
Joined: Tue Jan 10, 2006 6:20 am

Re: PHP 5.4 upgrade: from OJS 2.2.4 to 2.4.3

Postby JasonNugent » Sat Jan 18, 2014 10:20 am

Also, please make backups of both your PHP codebase and your mysql database. That's a long way to upgrade, and you may encounter problems. Having a backup will make it easy to roll back if you need to.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 891
Joined: Tue Jan 10, 2006 6:20 am

Re: PHP 5.4 upgrade: from OJS 2.2.4 to 2.4.3

Postby nahrizuladib » Thu Jan 23, 2014 8:23 am

thanks jason. yes, i'll be sure to have backups of both the codes and the database.
nahrizuladib
 
Posts: 19
Joined: Sat Aug 11, 2007 5:10 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests