OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Error in uploading articles

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Error in uploading articles

Postby NoMarie » Mon Jan 13, 2014 12:26 am

Hello,
I get the following error whenever I try to upload an article. This happens both as an author and when using the import plugins.

Fatal error: require_once() [function.require]: Failed opening required 'plugins/metadata/mods34/filter/Mods34SchemaArticleAdapter.inc.php' (include_path='.:/home/cjsdw867/public_html/classes:/home/cjsdw867/public_html/pages:/home/cjsdw867/public_html/lib/pkp:/home/cjsdw867/public_html/lib/pkp/classes:/home/cjsdw867/public_html/lib/pkp/pages:/home/cjsdw867/public_html/lib/pkp/lib/adodb:/home/cjsdw867/public_html/lib/pkp/lib/phputf8:/home/cjsdw867/public_html/lib/pkp/lib/pqp/classes:/home/cjsdw867/public_html/lib/pkp/lib/smarty:.:/usr/lib/php:/usr/local/lib/php') in /home/cjsdw867/public_html/lib/pkp/includes/functions.inc.php on line 31

I installed OJS via Softaculous onto our Hostpapa server space and am very new to OJS so don't really know how to troubleshoot. Any help appreciated.
NoMarie
 
Posts: 2
Joined: Mon Jan 13, 2014 12:17 am

Re: Error in uploading articles

Postby asmecher » Mon Jan 13, 2014 5:39 am

Hi NoMarie,

The noted file "plugins/metadata/mods34/filter/Mods34SchemaArticleAdapter.inc.php" seems to be missing from your installation; you'll need to find where your installation exists and put the file there. Note that if one file is missing you may have others as well.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8869
Joined: Wed Aug 10, 2005 12:56 pm

Re: Error in uploading articles

Postby NoMarie » Mon Jan 13, 2014 11:58 am

Thank you - so where can I get that file from and how do I figure out where it goes? There appear to be a lot of OJS-related files on our server right now...
NoMarie
 
Posts: 2
Joined: Mon Jan 13, 2014 12:17 am

Re: Error in uploading articles

Postby asmecher » Mon Jan 13, 2014 12:41 pm

Hi NoMarie,

Get the file by downloading the .tar.gz archive of the same version your server has installed. The full path within that archive is in my post above.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8869
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests