OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Double author listing in browse author

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Double author listing in browse author

Postby htimsxela » Thu Jan 09, 2014 6:17 pm

I have an issue with the 'browse author' option for my journal. I found an old forum posting that might be related but it was last updated in 2008.

I just uploaded multiple issues using the XML import tool. I immediately went to see what the issues looked like. While looking, I clicked on the 'browse authors' link. When browsing authors, many of them are listed twice but when clicked, they show the exact same information (they list the same papers and link to the same paper ids, etc).

For example, if I browse by author and click on "D" I get a list of authors as shown here https://journals.tdl.org/absel/index.ph ... hInitial=D

Note that 'Deguchi, Hiroshi' and 'Dunway, Mary M.' are listed twice. If you click on either name for Deguchi, you get the same exact listing of publications (in fact, the URL for each link is identical as well).

I noticed that this only occurred for authors that have multiple articles published in the journal. If you click on any of the non-duplicated name-links, you will notice that they all only list a single article under their name.

To test this, I created a test article for Dunway. Originally there was only one listing for her via the author browse. I went and create a test article for her, uploading it via the quicksubmit plugin. You'll note that there is now two listings for her and both listing list the same two articles.

Please help.
htimsxela
 
Posts: 7
Joined: Sun Apr 07, 2013 9:48 am

Re: Double author listing in browse author

Postby asmecher » Fri Jan 10, 2014 4:33 am

Hi htimsxela,

Have you made any modifications to your system?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: Double author listing in browse author

Postby htimsxela » Fri Jan 10, 2014 9:03 am

None to my knowledge. This is being hosted by Texas Digital Library on their servers.
htimsxela
 
Posts: 7
Joined: Sun Apr 07, 2013 9:48 am

Re: Double author listing in browse author

Postby asmecher » Fri Jan 10, 2014 9:10 am

Hi htimsxela,

Can you ask them whether there are any modifications in place?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: Double author listing in browse author

Postby htimsxela » Fri Jan 10, 2014 11:15 am

I've asked and they are supposed to get back to me. They don't know of any modifications, but they want to ask around to verify first.

I've fiddled a little bit more and found out the following. If I go into the editor page and go to 'editing' for the article, then click on 'review metadata' then scroll down and click 'save metadata' (making no changes to the metadata) the double listing disappears. I have to do it for all the articles that were uploaded by xml import for the author before the double posting disappears though.
htimsxela
 
Posts: 7
Joined: Sun Apr 07, 2013 9:48 am

Re: Double author listing in browse author

Postby htimsxela » Fri Jan 10, 2014 11:57 am

TDL says that they haven't made any modifications to the system. After my last post and finding that going to the metadata and saving again clears up the problem (which is a pain to do with over 2000 articles that I am uploading) I wondered if there is something missing from my xml file while uploading. So I've posted a sample of the xml file that I use (I've only included a single article though).


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE articles PUBLIC "-//PKP//OJS Articles and Issues XML//EN" "native.dtd">
<articles>


<article locale="en_US" language="en">
<title locale="en_US">The Ginseng Game</title>
<abstract locale="en_US">The Ginseng Game is designed to teach the principles generally associated with the tragedy of the commons and specifically with competition in industries susceptible to resource depletion. The game explicitly uses competitive forces to encourage groups to escalate commitment to short term profits while visually conveying resource depletion. Student teams must use the available information, “out of the box” critical thinking, problem solving, coordination, and cooperation to achieve the objective of long term industry sustainability. The game and debriefing can be run in a single class session. It can be delivered with or without computer presentation (game computations must be performed with the game’s MS Excel spreadsheet). The instructor calculates industry harvest and team performance data with an excel spreadsheet and may display that information with or without the aid of a presentation system.</abstract>
<author primary_contact="true"><firstname>Christopher</firstname>
<middlename>M.</middlename>
<lastname>Cassidy</lastname>
<email>chris@gmail.com</email></author>
<author><firstname>Dallas</firstname>
<lastname>Brozik</lastname>
<email>Dallas@gmail.com</email></author>
<date_published>2010</date_published>
<galley locale="en_US"><label>PDF</label><file><href src="http://tempfiles.net23.net/vol36/36cc.pdf" mime_type="application/pdf"/></file></galley></article>

</articles>
htimsxela
 
Posts: 7
Joined: Sun Apr 07, 2013 9:48 am

Re: Double author listing in browse author

Postby asmecher » Fri Jan 10, 2014 2:33 pm

Hi htimsxela,

Hmm, that does sound odd. I'd suggest trying the following...
  • Import an XML document so that the error shows itself
  • Generate a database dump, if possible configuring mysqldump to include one row per line in INSERT statements
  • Edit the document and save it to cause the problem to disappear
  • Generate another database dump, as above
  • Compare the two dumps to find out what entity changed.
Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: Double author listing in browse author

Postby htimsxela » Fri Jan 10, 2014 2:46 pm

Am I correct in assuming that this database dump has to be done from the command line? Or is there a way to do it from the web interface?
htimsxela
 
Posts: 7
Joined: Sun Apr 07, 2013 9:48 am

Re: Double author listing in browse author

Postby asmecher » Fri Jan 10, 2014 3:21 pm

Hi htimsxela,

OJS doesn't have a facility to create one via the web -- but you may have a tool like phpMyAdmin on your server to generate a database dump via the web.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: Double author listing in browse author

Postby asmecher » Tue Jan 21, 2014 5:37 am

Hi htimsxela,

Just a hunch: do you have multiple authors within the same submission designated as primary author? If so, that's the problem -- only one author should be designated primary.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: Double author listing in browse author

Postby htimsxela » Mon Feb 03, 2014 11:03 am

Nope. Only a single primary author is listed. Just for giggles, I actually removed the primary author tag and replaced it with a basic author tag, but the same thing still happens.

Thanks,
htimsxela
 
Posts: 7
Joined: Sun Apr 07, 2013 9:48 am

Re: Double author listing in browse author

Postby asmecher » Mon Feb 03, 2014 1:05 pm

Hi htimsxela,

Hmm -- I'm afraid it's back to the debugging suggestion listed above.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 2 guests

cron