OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Cant upgrade from version 2.4.2.0 to 2.4.3.0

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Cant upgrade from version 2.4.2.0 to 2.4.3.0

Postby masrook » Wed Jan 08, 2014 12:48 pm

Hi everyone,

I have been running ojs for quiet some time now (i am currently on version 2.4.2.0). From last few days i can't work on the site because it shows A Fatal error:
Fatal error: Out of memory (allocated 21757952) (tried to allocate 30720 bytes) in /home/thirdfro/public_html/ojs/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/UnitConverter.php on line 104
and so on and so forth.

Now i tried to upgrade it from 2.4.2.0 to 2.4.3.0 on screen when i try i get the error. the error report is in attached web shot. can you please help me, and i want to know incase i upgrade will i loose the previous files which i have right now on OJS.
any help will be appreciated.

Regards,
Masrook
Attachments
Screen Shot 2014-01-09 at 1.03.31 am.png
Screen Shot 2014-01-09 at 1.03.31 am.png (22.28 KiB) Viewed 651 times
masrook
 
Posts: 6
Joined: Fri Apr 26, 2013 12:01 am

Re: Cant upgrade from version 2.4.2.0 to 2.4.3.0

Postby JasonNugent » Thu Jan 09, 2014 7:01 am

Hi Masrook,

Your PHP process is running out of memory. There is a limit that you can set in your server's php.ini file that controls how much memory PHP is allowed to have. Please set it to something higher, like 128M, and try the upgrade again:

Code: Select all
memory_limit = 128M


Regards,
Jason
JasonNugent
Site Admin
 
Posts: 848
Joined: Tue Jan 10, 2006 6:20 am

Re: Cant upgrade from version 2.4.2.0 to 2.4.3.0

Postby masrook » Thu Jan 09, 2014 9:32 am

JasonNugent wrote:Hi Masrook,

Your PHP process is running out of memory. There is a limit that you can set in your server's php.ini file that controls how much memory PHP is allowed to have. Please set it to something higher, like 128M, and try the upgrade again:

Code: Select all
memory_limit = 128M


Regards,
Jason


Dear Jason

My PHP memory limit is already set to 128M. below is the attached screen shot which confirms that
Attachments
Screen Shot 2014-01-09 at 10.00.24 pm.png
Screen Shot 2014-01-09 at 10.00.24 pm.png (33.01 KiB) Viewed 474 times
masrook
 
Posts: 6
Joined: Fri Apr 26, 2013 12:01 am

Re: Cant upgrade from version 2.4.2.0 to 2.4.3.0

Postby JasonNugent » Thu Jan 09, 2014 11:55 am

Hi Masrook,

What version of PHP are you using? Before 5.2.1, the memory limit specified in php.ini needed to be enabled with PHP was installed. It'd be rare that this isn't the case, but I wanted to check. The error message you're receiving is indicating that PHP won't let you go above 20Mb.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 848
Joined: Tue Jan 10, 2006 6:20 am

Re: Cant upgrade from version 2.4.2.0 to 2.4.3.0

Postby masrook » Thu Jan 09, 2014 12:26 pm

JasonNugent wrote:Hi Masrook,

What version of PHP are you using? Before 5.2.1, the memory limit specified in php.ini needed to be enabled with PHP was installed. It'd be rare that this isn't the case, but I wanted to check. The error message you're receiving is indicating that PHP won't let you go above 20Mb.

Regards,
Jason

Thanks for the quick response, please take me out of this problem. I am attaching the screen shot which gives the details about PHP, Apache, Mysql etc
I will appreciate your help.

Regards,
Masrook
Attachments
Screen Shot 2014-01-10 at 12.52.51 am.png
Screen Shot 2014-01-10 at 12.52.51 am.png (17.21 KiB) Viewed 417 times
masrook
 
Posts: 6
Joined: Fri Apr 26, 2013 12:01 am

Re: Cant upgrade from version 2.4.2.0 to 2.4.3.0

Postby masrook » Thu Jan 09, 2014 12:30 pm

masrook wrote:
JasonNugent wrote:Hi Masrook,

What version of PHP are you using? Before 5.2.1, the memory limit specified in php.ini needed to be enabled with PHP was installed. It'd be rare that this isn't the case, but I wanted to check. The error message you're receiving is indicating that PHP won't let you go above 20Mb.

Regards,
Jason

Thanks for the quick response, please take me out of this problem. I am attaching the screen shot which gives the details about PHP, Apache, Mysql etc
I will appreciate your help.

Regards,
Masrook


also attached is the php.ini file
Attachments
php.ini
(37.22 KiB) Downloaded 8 times
masrook
 
Posts: 6
Joined: Fri Apr 26, 2013 12:01 am

Re: Cant upgrade from version 2.4.2.0 to 2.4.3.0

Postby JasonNugent » Fri Jan 10, 2014 7:15 am

Hi Masrook,

The php.ini file doesn't contain the version of PHP you are using so I still don't know. The config itself looks fine but some of those settings may be getting ignored.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 848
Joined: Tue Jan 10, 2006 6:20 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], ctgraham and 7 guests