OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS newer versions updates (2x to 3)

OJS development discussion, enhancement requests, third-party patches and plug-ins.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

OJS newer versions updates (2x to 3)

Postby nicknamed » Wed Nov 27, 2013 11:37 pm

Hi, simple question:
I need to install new installation in few months, probably earlier than new 3.0 comes out. What if I install version 2x now, then the website will have several journals with hundreds of articles and version 3.0 goes public, is the version 2 going to be easily updatable to version 3?
Should I wait for ver 3 even if I lose some potential customers, or should I go for version 2 now and then one afternoon update to 3 as it will be rather simple?
Thank you
Petr
nicknamed
 
Posts: 15
Joined: Mon Jul 01, 2013 6:06 am

Re: OJS newer versions updates (2x to 3)

Postby JasonNugent » Thu Nov 28, 2013 8:31 am

Hi Petr,

The full version of 3.0 will include at least some upgrade support from 2.4. In our own internal work, we do have a fair amount of that upgrade process working and spec'ed out, although there are parts of it that are still missing (subscriptions, for example). It also needs more testing before I would be comfortable in saying that it's ready to go.

One approach is this -- begin using 2.4 now. You don't necessarily need to jump to 3.0 when it first comes out. You could wait until a later point release (3.1, etc) which has a more thorough upgrade process in place.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: OJS newer versions updates (2x to 3)

Postby nicknamed » Thu Nov 28, 2013 11:28 am

OK, thank you. The thing is that I am already using 2.4 for a different site (ojs.journals.cz) and I struggle to get it working for google scholar. I registered for google scholar several months ago and it still does not work and google says that certain fields have different names so it may not recognize them, but that seems unlikely as you say ojs has perfect support for google scholar, but yet, as far as I researched I still think certain fields have different names so maybe that is the reason. I was thinking that in ver. 3.0 this will work for sure without doubts.
Petr
nicknamed
 
Posts: 15
Joined: Mon Jul 01, 2013 6:06 am


Return to OJS Development

Who is online

Users browsing this forum: No registered users and 0 guests