OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Please Help: Navigation Plugin and User Plugin not recognize

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Please Help: Navigation Plugin and User Plugin not recognize

Postby connexity » Wed Nov 20, 2013 12:21 pm

Please help use here...We contacted OJS so many time and no one helping use here:

1- I noticed that navigation plugin and user was not located in my block plugins. So I upload the folders directly in the plugin block folder. Now it shows up but only when I am in the setup screen. The upgrade link and other links are also missing from them in the block plugin page. It is appear as if the system has not recognized them. I need someone to help me to make this thing work...please help.

2- I also want to add Html link and Text link next to my current page PDF links. How do I accompolish that? My HTML component is not working.

Please help....I am not too technical.

Thanks
connexity
 
Posts: 3
Joined: Wed Nov 20, 2013 11:02 am

Re: Please Help: Navigation Plugin and User Plugin not recog

Postby asmecher » Wed Nov 20, 2013 1:22 pm

Hi connexity,

Where are you trying to contact us? This forum is the best place, but other contacts should be directing you here.

1. Those plugins should be included in your installation of OJS -- they come included. In any case, it sounds like these plugins are not registered with the system. To do so run "php tools/upgrade.php upgrade" on your server -- but please back up our database first in case it's in an intermediate state e.g. from an earlier failed upgrade.

2. It sounds like you want to edit your templates. The template for the Table of Contents is templates/issue/issue.tpl -- it's a Smarty template, which you can add HTML code to. See http://smarty.net for information about Smarty temlates.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9071
Joined: Wed Aug 10, 2005 12:56 pm

Re: Please Help: Navigation Plugin and User Plugin not recog

Postby connexity » Wed Nov 20, 2013 7:09 pm

1) I tried to run the script, but it gives the following error:
[pre-install]
[load: upgrade.xml]
[version: 2.4.2.0]
[schema: lib/pkp/xml/schema/signoff.xml]
[schema: lib/pkp/xml/schema/common.xml]
[schema: lib/pkp/xml/schema/groups.xml]
[schema: lib/pkp/xml/schema/log.xml]
[schema: lib/pkp/xml/schema/announcements.xml]
ERROR: Upgrade failed: DB: Table 'announcement_settings' already exists

2) I am not technical. All I want is to add a html and text link next to pdf lin, in current page. Can you provide me with the code so I can add it to the isssue.tpl? and where do I have to add it to?

Thanks
connexity
 
Posts: 3
Joined: Wed Nov 20, 2013 11:02 am

Re: Please Help: Navigation Plugin and User Plugin not recog

Postby asmecher » Thu Nov 21, 2013 11:28 am

Hi connexity,

1. Do you have "persist" turned on in config.inc.php? If so, turn it off and try again. Note: you MUST back up your database before working with the upgrade script. If it encounters a failure, restore from backup before trying again.

2. I'm not sure what you need. Have you uploaded HTML and text files as Editor under the submission's "Editing" page? You need to upload these as Galleys.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9071
Joined: Wed Aug 10, 2005 12:56 pm

Re: Please Help: Navigation Plugin and User Plugin not recog

Postby connexity » Thu Nov 21, 2013 3:08 pm

Hi,

The persist was turned off. This is extremely frustrating. Is there any way to fix this?

Thanks
connexity
 
Posts: 3
Joined: Wed Nov 20, 2013 11:02 am

Re: Please Help: Navigation Plugin and User Plugin not recog

Postby asmecher » Thu Nov 21, 2013 3:38 pm

Hi connexity,

Can you PM me a URL to your installation?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9071
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: victorp, Yahoo [Bot] and 4 guests