OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Browse by author

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Browse by author

Postby SkyAn » Tue Nov 12, 2013 4:57 am

Now in journal it is a little more than 300 articles. And when I select viewing on authors, from the list only one author, and others aren't displayed. In what there can be a problem?
SkyAn
 
Posts: 8
Joined: Tue Nov 12, 2013 4:16 am

Re: Browse by author

Postby asmecher » Tue Nov 12, 2013 11:35 am

Hi SkyAn,

Have you checked your error log? Can you post a link to the journal in question?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: Browse by author

Postby SkyAn » Thu Nov 14, 2013 9:26 am

How I can check error log in system? Link on journal http://ojs.uni.me/
I don't know how it's, but when I added new article with fake name. It's name showed in the list
SkyAn
 
Posts: 8
Joined: Tue Nov 12, 2013 4:16 am

Re: Browse by author

Postby asmecher » Thu Nov 14, 2013 9:54 am

Hi SkyAn,

Ah -- the problem is most likely to do with UTF8. The "A" is the only letter that's standard ASCII rather than involving a multibyte UTF8 sequence. What are your settings for client_charset, database_charset, connection_charset, and charset_normalization in config.inc.php?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: Browse by author

Postby SkyAn » Fri Nov 15, 2013 1:43 am

client_charset utf-8
connection_charset off.
database_charset off.
charset_normalization off.
SkyAn
 
Posts: 8
Joined: Tue Nov 12, 2013 4:16 am

Re: Browse by author

Postby asmecher » Fri Nov 15, 2013 8:32 am

Hi SkyAn,

That's the problem; you'll need to set connection_charset and database_charset to utf8, but you'll probably also need to transcode your database so that existing data is entered in the new encoding. There are some instructions online for other applications e.g. Moodle; the process is similar. See http://docs.moodle.org/23/en/Converting_your_MySQL_database_to_UTF8 for example.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: Browse by author

Postby SkyAn » Mon Nov 18, 2013 3:13 am

I set connection_charset and database_charset to utf8. And transcode DB to utf8_general_ci. Now I have a problem with the search and there are no changes in the list of authors.
SkyAn
 
Posts: 8
Joined: Tue Nov 12, 2013 4:16 am

Re: Browse by author

Postby asmecher » Mon Nov 18, 2013 10:00 am

Hi SkyAn,

Note that the author list is cached, so you'll also have to flush the database cache (as Site Administrator) or you may have old data affecting the query results. It looks like your installation is currently down; let me know when it's back up and I'll take a look.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: Browse by author

Postby SkyAn » Tue Nov 19, 2013 4:50 am

Now I have problem with encoding. All not english text in abracadabra. You can look in www.ipri-ojs.uni.me It's terribly. Can you help me with encoding text?
SkyAn
 
Posts: 8
Joined: Tue Nov 12, 2013 4:16 am

Re: Browse by author

Postby asmecher » Tue Nov 19, 2013 12:10 pm

Hi SkyAn,

This indicates that the database was not transcoded from its previous format into proper UTF8.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: No registered users and 3 guests