OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Registering at OpenArchives

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Registering at OpenArchives

Postby rauf » Wed Nov 06, 2013 8:08 am

Hi,

I'm trying to register our journal at OpenArchives and when I submit our OAI, the validation test returns this:

[FAIL] baseURL supplied 'http://MYDOMAIN/index.php/MYJOURNAL/oai' does not match the baseURL in the Identify response 'http://MYDOMAIN/MYJOURNAL/oai'. The baseURL you enter must
EXACTLY match the baseURL returned in the Identify response. It must match in case (http://Wibble.org/ does not match http://wibble.org/) and include any trailing slashes etc.

What can I do to fix this? The journal is on OJS 2.4.2.
rauf
 
Posts: 9
Joined: Mon Jun 06, 2011 6:29 am

Re: Registering at OpenArchives

Postby asmecher » Wed Nov 06, 2013 10:59 am

Hi rauf,

Are you using mod_rewrite to modify the way URLs are presented in your installation, or specifying any base_url directives in config.inc.php?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Registering at OpenArchives

Postby rauf » Wed Nov 06, 2013 1:09 pm

Hi,

I'm using nginx, and there's not any redirect in base_url in config.inc.php.
rauf
 
Posts: 9
Joined: Mon Jun 06, 2011 6:29 am

Re: Registering at OpenArchives

Postby asmecher » Wed Nov 06, 2013 1:23 pm

Hi rauf,

Can you PM me your OAI URL?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Registering at OpenArchives

Postby asmecher » Thu Nov 07, 2013 9:41 am

Hi rauf,

Have you enabled restful_urls in config.inc.php? If so, you need to configure some kind of URL rewriting in order for that to function properly. I'd suggest disabling restful_urls unless you configure rewriting as well.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Registering at OpenArchives

Postby rauf » Thu Nov 07, 2013 10:37 am

Hi,

I disabled restful_urls as you suggested and it worked! Thank you Alec for your help!
rauf
 
Posts: 9
Joined: Mon Jun 06, 2011 6:29 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron