OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Installing OJS error (instalation doesn't start)

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Installing OJS error (instalation doesn't start)

Postby coke » Wed Nov 08, 2006 9:49 am

I'm trying to install OJS, and followed the instruction in the README file.

Any way when I go to the path of OJS http://www.mu.cl/ojs/ it throw the following errors, and then a blank page:

Notice: Only variable references should be returned by reference in /home/mucl/public_html/ojs/classes/core/Registry.inc.php on line 38

Notice: Only variable references should be returned by reference in /home/mucl/public_html/ojs/classes/core/Registry.inc.php on line 38

Warning: Cannot modify header information - headers already sent by (output started at /home/mucl/public_html/ojs/classes/core/Registry.inc.php:38) in /home/mucl/public_html/ojs/classes/core/Request.inc.php on line 33


I downloaded OJS this morning from the original site so is the last version.

Thanks
coke
 
Posts: 4
Joined: Wed Nov 08, 2006 9:42 am

Postby coke » Wed Nov 08, 2006 9:52 am

I found out this topic

viewtopic.php?t=1177&highlight=install

and they say is a problem with PHP...

anyway, the page is blank for me after those notices and warning.

Thanks
coke
 
Posts: 4
Joined: Wed Nov 08, 2006 9:42 am

Postby asmecher » Wed Nov 08, 2006 10:00 am

Hi Coke,

A blank page usually indicates a PHP error. Try setting PHP's display_errors option to E_ALL; this might provide more information. If you don't have access to modify php.ini, try adding the following line near the top of index.php:
Code: Select all
ini_set('display_errors', E_ALL);
If you see a blank page after submitting the installation form, it's typically because you're missing the MySQL driver in your PHP configuration.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8869
Joined: Wed Aug 10, 2005 12:56 pm

Postby coke » Wed Nov 08, 2006 10:55 am

I did add ini_set('display_errors', E_ALL);

but E_ALL doesn't show all the errors? I tryed with E_ALL and E_ERROR but both show the warnings... maybe my server doesnt allow ini_set?

:cry:

If you see a blank page after submitting the installation form, it's typically because you're missing the MySQL driver in your PHP configuration.


There is no installation form.

thanks for the fast reply! I'm lost
coke
 
Posts: 4
Joined: Wed Nov 08, 2006 9:42 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest