OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Links and images submitted in content editor not working

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Links and images submitted in content editor not working

Postby gemusehandler » Thu Sep 26, 2013 10:21 am

Hi, we recently upgraded OJS to 2.4.2. Everything works but... the links and images that were submitted using the content editor (now TinyMCE) aren not working.

Take for instance http://abe.tudelft.nl/issue/archive. The line "PDF // ePUB // Paperback: Full colour $34 // 254 pages" contains three hyperlinks. Role-over hoover works but Safari's webinspector shows that the word PDF is just contained between <a> PDF </a>. The content editor shows a full internal link.

In a similar way the images that were uploaded in the content editor have gone missing on the html page while they are clearly visible in the content editor.

Any idea what is causing this? Help is much appreciated.
gemusehandler
 
Posts: 30
Joined: Sun May 19, 2013 12:30 am

Re: Links and images submitted in content editor not working

Postby asmecher » Thu Sep 26, 2013 10:36 am

Hi gemusehandler,

Check the allowed_html setting in your config.inc.php configuration file (and see the template in config.TEMPLATE.inc.php). We changed the HTML filter we were using and the new one may be stricter.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Links and images submitted in content editor not working

Postby gemusehandler » Sat Oct 19, 2013 5:54 am

You were quite right. Thank you!
gemusehandler
 
Posts: 30
Joined: Sun May 19, 2013 12:30 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 1 guest