OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Submissions SendEmail attachments not working

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Submissions SendEmail attachments not working

Postby botheaj » Thu Oct 17, 2013 12:17 pm

Not sure if this is a permissions issue or bug, but when using the Notify Author email button under Editor Decision (at /CS/editor/emailEditorDecisionComment?articleId=) Whenever I click "Upload" to attach a file to the decision, I get sent to the /send page (/CS/editor/emailEditorDecisionComment/send) and nothing happens, just a screen that said "Send Email". Can someone offer up some advice?
Here's where I'm at:
ojsissue1.png
ojsissue1.png (16.76 KiB) Viewed 486 times

And when I submit I get this:
ojsissue2.png
ojsissue2.png (4.2 KiB) Viewed 486 times
botheaj
 
Posts: 5
Joined: Wed Sep 04, 2013 12:21 pm

Re: Submissions SendEmail attachments not working

Postby JasonNugent » Fri Oct 18, 2013 3:52 am

Hi botheaj,

You don't say which version of OJS you are using. From the looks of it, the template rendering is being halted in mid-page, so something is probably being logged to your Apache or PHP error log. If you can provide that information, we can investigate further.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 849
Joined: Tue Jan 10, 2006 6:20 am

Re: Submissions SendEmail attachments not working

Postby botheaj » Fri Oct 18, 2013 5:54 am

We're on version 2.4.2, upgraded from 2.3.8. I figured it out though and it is a permissions issue, I guess my real question is, what should the permissions on the shared directory actually be?
I currently have it that the apache user is the owner with rwx, root is the group with rw, and everyone has 0. Should this be applied to the entire shared files directory, including the journals, site and temp dirs?
botheaj
 
Posts: 5
Joined: Wed Sep 04, 2013 12:21 pm

Re: Submissions SendEmail attachments not working

Postby JasonNugent » Fri Oct 18, 2013 10:57 am

There are recommended permissions settings located in the docs/README that came with your OJS code distribution. Generally, the web server needs to be able to write to the cache/ public/ and files/ directories. The files/ directory should be located outside of your web tree for security reasons.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 849
Joined: Tue Jan 10, 2006 6:20 am

Re: Submissions SendEmail attachments not working

Postby botheaj » Fri Oct 18, 2013 11:21 am

Last questions, as it's somewhat related.

We have two web servers that are load balancing and each point back to an NFS share for the shared files directory. Should I also point the cache directories to the NFS share as well, so that they are consistent for both?
botheaj
 
Posts: 5
Joined: Wed Sep 04, 2013 12:21 pm

Re: Submissions SendEmail attachments not working

Postby JasonNugent » Fri Oct 18, 2013 11:36 am

Sure, that's fine, although it isn't important. OJS will simply update the cache directory it has access to, in real time. Where things might get out of sync is when you 'clear cache' from the journal admin interface. If there are separate shared directories, you'd have to clear in both places, perhaps manually.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 849
Joined: Tue Jan 10, 2006 6:20 am

Re: Submissions SendEmail attachments not working

Postby botheaj » Fri Oct 18, 2013 11:59 am

Thanks for your help, everything is working now.
botheaj
 
Posts: 5
Joined: Wed Sep 04, 2013 12:21 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 4 guests