OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



RefBacks not shown

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

RefBacks not shown

Postby mbria » Tue Oct 15, 2013 2:43 am

Hi,

I enabled the refback plugin (and "php tools/upgrade.php update" to register) and I didn't see the Refback div in the article's summary.
I read the Manual and I didn't see any reference about this.

Does any body knows how to make the RefBack section visible in the article's summary?

Cheers,
m.
mbria
 
Posts: 292
Joined: Wed Dec 14, 2005 4:15 am

Re: RefBacks not shown

Postby asmecher » Tue Oct 15, 2013 9:37 am

Hi Marc,

Is there an entry for the referral plugin in the versions table of the database?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: RefBacks not shown

Postby mbria » Wed Oct 16, 2013 3:15 am

Yep.

Code: Select all
major: 1
minor: 0
revision: 0
build: 0
date_installed: 2011-04-06 15:44:30
current: 1
product_type: plugins.generic
product: referral
product_class_name: ReferralPlugin
lazy_load: 1
sitewide: 0


May be "sitewide" must be 1?

Thanks for your help Alec,
m.
mbria
 
Posts: 292
Joined: Wed Dec 14, 2005 4:15 am

Re: RefBacks not shown

Postby asmecher » Wed Oct 16, 2013 8:34 am

Hi Marc,

No, that's as it should be. What version of OJS are you running?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: RefBacks not shown

Postby mbria » Thu Oct 17, 2013 12:41 am

2.3.6 and DB is updated to this version. :shock:

The magazine is hosted in my multiOJS, so I reviewed other magazines to see what happens and looks like it's a general issue.
Let me check the templates... so it could be related with a couple of changes I made in them.

Thanks for your help Alec,
m.
mbria
 
Posts: 292
Joined: Wed Dec 14, 2005 4:15 am

Re: RefBacks not shown

Postby asmecher » Thu Oct 17, 2013 8:53 am

Hi Marc,

The relevant code is plugins/generic/referral/ReferralPlugin.inc.php, around the handleAuthorTemplateInclude function (which has a slightly convoluted execution path). A few error_log statements there to find out what's being called and what isn't may help. As far as I can recall, none of this changed up to 2.3.8, and changes between that and 2.4.2 will be primarily around coding conventions and related tweaks.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Re: RefBacks not shown

Postby mbria » Fri Oct 18, 2013 12:37 am

Thanks Alec.

I suspect I won't need to dig so deep and will be a forked template issue.

See you soon,
m.
mbria
 
Posts: 292
Joined: Wed Dec 14, 2005 4:15 am


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests