OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Articles suddenly miss in OJS submission process.

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Articles suddenly miss in OJS submission process.

Postby ayoladokun » Thu Oct 10, 2013 2:27 am

Hello,
I have been having this problem since i tried to upgrade from version 2.2.4 to 2.4.2. I was not successful in the upgrade. It all started whenmy email icon button attached to every email address in OJS refused to sent emails to private domains 9like university domains), then i tried to upgrade version. I failed to do it. I managed to resolve the email issue later only to find out that the articles in my submission process are no longer showing the links. It is showing that i still have 3 articles in 'in review', 4 in 'in editing', but when i go to the review page as an editor, or when i go the the 'in editing page as an editor, the link appears blank. Even my archives are all blank in OJS. the last issue that i published earlier still shows the link to the abstracts and the pdfs, but when i click the links, they all open a new tab, but are blank. I went to my directory that the articles are supposed to be in my server, they are all intact in their folders. I even checket the article table on my database, they are all there and intact. I am now wondering why those links were not showing. I could have restored my backup (cos i normally back my website up), but there have been new articles that are in editing since my last backup.
I have attached a screenshot of what i am talking about. in the "Submissions in Review" page, there are supposed to be three article links appearing there. It is saying NO SUBMISSION. if you look at the side bar, you will see that there are supposed to be 3 submissions there in the IN REVIEW part of the page.
It looks like there is a broken link between my pages in OJS and where the article are on my server (because all the articles are in the server and are intact .../files/journal/1/articles...)
Please I need your assistance. When you are discribing what i should do to get my links back, please explain WHERE i have to do and WHERE i have to do it.
I have a bit of knowledge about PHP and using, managing and editing codes. I am not an expert though.
Your help will be much appreciated
Attachments
saacdhe screenshot.jpg
screenshot of my issue
saacdhe screenshot.jpg (186.76 KiB) Viewed 570 times
ayoladokun
 
Posts: 4
Joined: Thu Oct 10, 2013 1:55 am

Re: Articles suddenly miss in OJS submission process.

Postby JasonNugent » Thu Oct 10, 2013 6:48 am

Hi ayoladokun,

I guess my first question is whether or not you had errors during the upgrade process, itself. You mention that it was not successful - were there errors that appeared? Anything in your server logs?

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 791
Joined: Tue Jan 10, 2006 6:20 am

Re: Articles suddenly miss in OJS submission process.

Postby ayoladokun » Fri Oct 11, 2013 6:08 am

I did not check for the error log at that time. what was happeneing that i remember is that when i asked the OJS (in the system information page) to check for updates, it tried to update and said the update was sucessful, but the update was to version 2.1.0 (my initial version is 2.2.4) This did not look like an upgrade to me. It looked like a downgrade. But when i go back into the system information page after the upgrade, it was still version 2.2.4. I downloaded the 2.2.4 to 2.4.2 patch, I saw how to upgrade it, but i did not know WHERE and really HOW to apply the patch (I saw in other forum that i had to run a commandline tool in my OJS directory, But I really do not know where the commandline is on my OJS directory. I also do not know how to apply it). I just copied it into my OJS root directory. Nothing hapened after that. But I can access every part of my OJS directory. The email issue seem to have been resolved. But i just cannot see my links to all my articles anymore. Is there no part of the filses on the root directory that i can edit to bring them back? The abstracts and the PDFs of the issue i had already created has also disappeared. But the documents themselves are still intact in the folders on my server and they are still in place. I just want the links to appear in the submission pages so that the editing can continue.
ayoladokun
 
Posts: 4
Joined: Thu Oct 10, 2013 1:55 am

Re: Articles suddenly miss in OJS submission process.

Postby JasonNugent » Sat Oct 12, 2013 10:44 am

Hi ayoladokun,

OJS will not downgrade your site when it performs a version check, nor will it apply the patches downloaded automatically. At this point, since I am unsure of what has been done to your site during your upgrade attempt would be to restore your site from a backup and read the documentation that comes with OJS regarding upgrading. There are detailed instructions in the file located in the docs/ directory in your OJS directory, called UPGRADE.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 791
Joined: Tue Jan 10, 2006 6:20 am

Re: Articles suddenly miss in OJS submission process.

Postby ayoladokun » Sat Oct 12, 2013 4:29 pm

Thanks a lot. I read the upgrade documentation. The documentation explained how to do the upgrade, but did not give a step by step analysis of where to perform each task. For example, the doc said that i need to apply the patch using the coomandline tool. Which command line? Where do i initiate the commandline? If i can get that, i know what to type. Besides, if it is possible, i would like to know where to edit the code that shows the snapshot page i attached above. Everything works well in the ojs now except the links to my articles. All i just want is to fix my links back. I restored my backup already. I do not want to upgrade again for now unless i get a very clear step by step on how to do it. If i can know which file to edit as regards my attachment above, i will work on it externally before i touch my live website.
ayoladokun
 
Posts: 4
Joined: Thu Oct 10, 2013 1:55 am

Re: Articles suddenly miss in OJS submission process.

Postby JasonNugent » Sun Oct 13, 2013 4:21 pm

Hi ayoladokun,

The UPGRADE document tells you exactly what to run. I quote:

To update by patching, download the appropriate patch file for your current
version of OJS and run the following command from your OJS directory:

$ patch -p1 < PATCH_FILE

"PATCH_FILE" should be replaced with the path to the decompressed patch file
that was downloaded, e.g. "ojs-2.3.1_to_2.3.2.patch".

Alternatively, there is a command-line tool to automatically download and apply
the appropriate patch to upgrade to the latest release. To use this tool run the
following command from your OJS directory:

$ php tools/upgrade.php patch


I can't offer insights into why your links are not working unless you provide some sort of error message that is appearing when you click on them. There must be something showing up in either PHP or Apache's error log.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 791
Joined: Tue Jan 10, 2006 6:20 am

Re: Articles suddenly miss in OJS submission process.

Postby ayoladokun » Mon Oct 14, 2013 4:01 am

Thanks. I saw that line. I must confess i do not know WHERE to run the commandine is in my OJS directory. When you mean my OJS directory, I assume you mean my OJS root directory.
That is exactly what i need a step by step guide to. E.G., is it the tool folder in my OJS directory I go to to run the command? Do i have to download any software to run the command line? Idf so, what software. After downloading the patch (I have done that already), where do i extract the file to? is it my OJS directory? After that where exactly do i go to in my OJS directory (I mean what do i click-there are many files and folders in my OJS directory). Those are the guides i need. I am really sorry that i am giving much trouble. Like i told you before, i am not really an expert in this.
ayoladokun
 
Posts: 4
Joined: Thu Oct 10, 2013 1:55 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 2 guests

cron