OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems with HTML in Journal Description Box

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Problems with HTML in Journal Description Box

Postby Realitas » Mon Sep 30, 2013 6:31 am

Dear Ojs friends,
first of all I must mention the fact that I am a completely newbie to OJS, but I was able to install it and make it run successfully, and this first step is ok.
I like very much OJS, and I am building step by step my ideal journal interface.

A problem that seems unsolvable to me is the following:

days ago, under the box about Journal Description in the Jornal Management Setup Page (in the "Step 5. Customizing the look" menu), I saw some possible buttons. One of those buttons was HTML, but when I clicked the TinyMCE plugin seemed not present, there was an error. On the other side, I had anyway read in the guide that I could insert HTML text inside the box, but the tags seemed to be recognized as normal text (verysimply, I wanted to center the text of Journal Description by using the basic <p align="center> </p> tag). In addition, today I am not seeing any button under the box anymore, and besides the HTML tags are still unrecognized.

This is starting to become very frustrating... can you help me?

Thanks in advance
Adalberto
Realitas
 
Posts: 4
Joined: Mon Sep 30, 2013 6:19 am

Re: Problems with HTML in Journal Description Box

Postby asmecher » Mon Sep 30, 2013 9:00 am

Hi Adalberto,

Can you include more information, like screenshots or text of error messages?

BTW, there is a cache file related to TinyMCE that needs to be flushed if you've changed your journal's URL during the installation process; it's a .gz file in the cache/ directory. If you have moved your installation, delete that file in order to cause it to be regenerated.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with HTML in Journal Description Box

Postby Realitas » Tue Oct 01, 2013 2:59 am

Hi Alec,
thanks for your reply.

First of all, I flushed the .gz in cache/ directory, as you suggested.
There was a little improvement: as you can see in screenshot 2, I can see the "Upload an image" button under the box now, at least. But some days ago, I could see also at least a Bold, an Italic, and a HTML button too...

Anyway, the main problem is still there: I simply wanted to center the journal description in homepage (see screenshot 1), but if I insert some html tags in the descrption box in the setup menu (as shown in screenshot 3), the result is that those tags are unrecognized and are ahown as normal text in the homepage (as shown in screenshot 4 in my next post).

I am quite sure it is caused by a naive mistake of mine, but I cant understand what it might be.

Thanks for your patience!

Adalberto
Attachments
screen3.jpg
screen3
screen3.jpg (266.09 KiB) Viewed 968 times
screen2.jpg
screen2
screen2.jpg (248.15 KiB) Viewed 968 times
screen1.jpg
Screen1
screen1.jpg (262.17 KiB) Viewed 968 times
Realitas
 
Posts: 4
Joined: Mon Sep 30, 2013 6:19 am

Re: Problems with HTML in Journal Description Box

Postby Realitas » Tue Oct 01, 2013 4:25 am

SEE THE POST ABOVE...

This is the screen 4
Attachments
screen4.jpg
screen4
screen4.jpg (267.59 KiB) Viewed 963 times
Realitas
 
Posts: 4
Joined: Mon Sep 30, 2013 6:19 am

Re: Problems with HTML in Journal Description Box

Postby asmecher » Tue Oct 01, 2013 7:53 am

Hi Adalberto,

After you deleted the .gz file, was it re-generated in the cache directory? If not, you probably need to fix your file permissions there.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with HTML in Journal Description Box

Postby Realitas » Tue Oct 01, 2013 10:02 am

Hi Alec,
no, actually, no new .gz file is in the directory now. What do I have to do?
Realitas
 
Posts: 4
Joined: Mon Sep 30, 2013 6:19 am

Re: Problems with HTML in Journal Description Box

Postby asmecher » Tue Oct 01, 2013 11:18 am

Hi Realitas,

Check file permissions on the cache/ directory and its contents. See http://pkp.sfu.ca/wiki/index.php/PKP_Frequently_Asked_Questions#I.27m_having_file_permission_problems.3B_how_should_I_set_file_permissions.3F.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Google [Bot] and 1 guest