OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems with OJS system

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Problems with OJS system

Postby stellamsrabbitoyeah » Tue Sep 10, 2013 6:19 pm

My version is 2.4.2.0, upgraded from 2.3.5.0 and there is a problem with DOI which I cannot solve after upgrading.

1. I cannot find “DOI Prefix” or “DOI Suffix” on the “Journal Manager----Setup----1.Details” page. Where can I find these two options?
2. The system automatically generates DOI for every single article. How to stop the system from AUTOMATICALLY generating DOIs?
3. How to make the artificially generated DOIs instead of the automatically generated ones displayed on the web page?
Who can help? Please!!! :cry: :cry: :cry: :cry: :cry: :cry:
stellamsrabbitoyeah
 
Posts: 3
Joined: Tue Sep 10, 2013 1:15 am

Re: Problems with OJS system

Postby asmecher » Tue Sep 10, 2013 8:26 pm

Hi stellamsrabbitoyeah,

Have a look at http://pkp.sfu.ca/wiki/index.php/DOIPluginsDocumentation.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9212
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with OJS system

Postby stellamsrabbitoyeah » Wed Sep 11, 2013 6:34 pm

Hi,
Thanx for your wiki. I still didn't find the way to solve my problem. The page teaches us how to assign DOIs while my problem basically is I cannot find the place to assign DOIs. My "DOI prefix" and "DOI suffix" both are not displayed on the page. What should I do?
Thank you very much!

Best Regards,
Stellamsrabbitoyeah
stellamsrabbitoyeah
 
Posts: 3
Joined: Tue Sep 10, 2013 1:15 am

Re: Problems with OJS system

Postby swing » Thu Sep 12, 2013 2:42 pm

Hi stellamsrabbitoyeah,

I am not sure if I understand what you would really like to do with DOIs, but lets answer you first 3 questions and then we will see further:
1. The DOI settings moved from the Journal Management > Setup 1 to a plug-in. After you enabled the DOI plug-in (Journal Management > System Plugins > Public Identifier Plugins > DOI > Enable) you can configure the plug-in/go to the settings page (Journal Management > System Plugins > Public Identifier Plugins > DOI > Settings). There you will find the options for DOI Prefix and Suffix.
2. If you don't want to use DOIs you will have to disable the DOI plug-in (Journal Management > System Plugins > Public Identifier Plugins > DOI > Disable).
3. What do you mean by "artificially generated DOIs"?
If DOI plug-in is used, i.e. enabled and configured, the DOIs will be automatically generated and stored when the publishing object (e.g. article) is used (e.g. when viewing the article) and thus displayed on the web page.

I hope this helps a little bit. Else, please try to better explain what is your current situation and what would you like to achieve.

Best
Bozana Bokan
swing
 
Posts: 144
Joined: Tue Oct 09, 2007 2:59 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron