OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



<e> not shown in title

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

<e> not shown in title

Postby digital » Tue Sep 03, 2013 3:01 pm

Hello,

I have such title in Edit Metadata:
Grafema su pagrindu <e>: sudėtinių grafemų ir morfemų santykis ankstyvojoje Simono Daukanto leksikografijoje
after I save article metadata, title is displayed without <e>:
Grafema su pagrindu : sudėtinių grafemų ir morfemų santykis ankstyvojoje Simono Daukanto leksikografijoje

How can I make <e> appear in an article title?

Thanks,
Nerijus
digital
 
Posts: 22
Joined: Tue Oct 11, 2011 9:41 am

Re: <e> not shown in title

Postby asmecher » Tue Sep 03, 2013 3:12 pm

Hi Nerijus,

See the allowed_html setting in config.inc.php to make sure the <e> tag is permitted.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9233
Joined: Wed Aug 10, 2005 12:56 pm

Re: <e> not shown in title

Postby digital » Tue Sep 03, 2013 5:33 pm

allowed_html = "<a href|target> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <b> <i> <u> <img src|alt> <sup> <sub> <br> <p>"
it is the default setting. Should <e> be added by default too?

Edit: I added <e> afer <p> - didn't help.
digital
 
Posts: 22
Joined: Tue Oct 11, 2011 9:41 am

Re: <e> not shown in title

Postby asmecher » Mon Sep 09, 2013 5:09 pm

Hi Nerijus,

Sorry, I misunderstood your situation. Remove <e> from allowed_html, and rather than using "<e>" in the title field, use "&lt;e&gt;" -- the "<" and ">" characters need to be escaped like this.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9233
Joined: Wed Aug 10, 2005 12:56 pm

Re: <e> not shown in title

Postby digital » Tue Sep 10, 2013 5:14 am

It helped, thanks! But actually I imported the xml file by using Articles & Issues XML Plugin, and xml file has <e> escaped - Grafema su pagrindu &lt;e&gt;...
Why didn't it import correctly?
digital
 
Posts: 22
Joined: Tue Oct 11, 2011 9:41 am

Re: <e> not shown in title

Postby digital » Tue Sep 10, 2013 6:56 am

I exported too, just to see how xml looks like:
Grafema su pagrindu &amp;lt;e&amp;gt;...
digital
 
Posts: 22
Joined: Tue Oct 11, 2011 9:41 am

Re: <e> not shown in title

Postby asmecher » Tue Sep 10, 2013 7:41 am

Hi digital,

Believe it or not, you have to double-escape these in XML import -- &amp;lt; and &amp;gt; (once for XML, once for HTML).

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9233
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron