OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems sending notifications by email

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Problems sending notifications by email

Postby Citein » Mon Aug 12, 2013 10:15 am

Hi everyone!

I am writting because We are having problems sending notifications to ours authors and reviewers. When we select a revisor for an article we have to send an email asking him to answer our request. We also have the option to send notifications to all the authors for example.

The problem is that all this kind of communications are not working nowadays. No one is receiving any kind of email. As there are being a lot of changes in our institutional computer services and network we are doubting if it could be a configuration problem.

Could you please give us an idea of what could be the problem?

Thank you very much in advance,

Centro de Información Técnica-LATU http://ojs.latu.org.uy
Citein
 
Posts: 12
Joined: Mon Apr 25, 2011 7:58 am

Re: Problems sending notifications by email

Postby asmecher » Mon Aug 12, 2013 10:23 am

Hi Citein,

If you're able to reproduce this behavior using your own email account, that'll help immensely in debugging.

Check the obvious places -- i.e. your spam folder -- to see if the messages are getting trapped there. If so, try viewing the message's headers. Spam filters attach explanations for why they were flagged.

On the server side, see if you can access the mail sending logs. If you're using a local MTA (i.e. you're not using SMTP) these should be somewhere on the machine that OJS is installed on, such as /var/logs/exim/... or similar, depending on that server's mail configuration.

One common problem is recent trends in the adoption of SPF (Sender Protection Framework) rules. OJS 3.0 will include a new approach to email that won't fall on the wrong side of these rules; see http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=8085.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems sending notifications by email

Postby Citein » Tue Aug 13, 2013 10:20 am

Dear Alec, thank you very much for your kind answer.

Yes I tried to reproduce the problem with differents email accounts and nothing happens.

I think that it is a problem with our server, I sent your answer to our networking team to see if they change something of what you mention.

Thank you again,

Lorena
Citein
 
Posts: 12
Joined: Mon Apr 25, 2011 7:58 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests