OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS server with many processes

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

OJS server with many processes

Postby raickonen » Fri Jan 07, 2011 5:42 am

Hello,

I have an ubuntu server 10.04, with nginx and php-fpm. Before that the system was 8.04 with apache2.

We still have the same problem before the upgrade of the system, sometimes ojs starts many processes until crash the system. Only with a reboot we can fix the problem.

I attached the errors logs, showing many processes.

I think the problem is:

PHP Fatal error: Cannot return string offsets by reference in /var/www/seer/ojs/lib/pkp/classes/core/DataObject.inc.php on line 55
[06-Jan-2011 18:42:21] ojs2: 404 Not Found
[06-Jan-2011 18:47:35] ojs2: 404 Not Found
[06-Jan-2011 18:49:31] PHP Fatal error: Call to undefined method JournalOAI::prepInput() in /var/www/seer/ojs/lib/pkp/classes/oai/OAIUtils.inc.php on line 90
[06-Jan-2011 18:53:27] ojs2: 404 Not Found

But I'm not sure how solve this problem. Can you give any or patch for this problem?

Luciano
IT Technician
Attachments
php5-err_log.txt
PHP error log
(301.22 KiB) Downloaded 101 times
php5-fpm_log.txt
Processes
(16.31 KiB) Downloaded 63 times
raickonen
 
Posts: 34
Joined: Tue Nov 16, 2010 10:39 am

Re: OJS server with many processes

Postby makouvlei » Wed Jul 10, 2013 12:19 am

Hi Luciano, did you ever solve this problem "Call to undefined method JournalOAI::prepInput() \lib\pkp\classes\oai\OAIUtils.inc.php:89"? I run into the same at http://www.ajol.info/index.php/index/oa ... fix=oai_dc

Thanks
Jannie
makouvlei
 
Posts: 16
Joined: Wed Nov 17, 2010 2:56 am

Re: OJS server with many processes

Postby raickonen » Wed Jul 10, 2013 8:46 am

Hi Jannie,

It was two years ago, I'm not sure,but I think we upgraded from OJS 2.2.x to 2.3.5 with all recommended patches. Now we considering upgrade to 2.4.2.


What version are you using?


Luciano
raickonen
 
Posts: 34
Joined: Tue Nov 16, 2010 10:39 am

Re: OJS server with many processes

Postby makouvlei » Wed Jul 10, 2013 9:42 am

Thanks Luciano, we're on 2.3.7. The code for OAIUtils.inc.php on 2.3.7 and 2.4.2 looks identical. Will have a closer look and see if I can figure it out..
makouvlei
 
Posts: 16
Joined: Wed Nov 17, 2010 2:56 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 3 guests