OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Random errors on OJS

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Random errors on OJS

Postby Farrukh » Mon Jun 10, 2013 9:02 am

I have OJS installation and it was working perfectly good. All of a sudden I start encountering random errors. Some are mentioned below:

While clicking TOC of current issue
Fatal error: require_once() [function.require]: Failed opening required 'HTMLPurifier.includes.php' (include_path='') in /home/techpubl/public_html/lib/pkp/classes/core/String.inc.php on line 414

While clicking any article:
Fatal error: require_once() [function.require]: Failed opening required 'HTMLPurifier.includes.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/rohatool/php') in /home/techpubl/public_html/lib/pkp/classes/core/String.inc.php on line 414

While exporting issues using Articles & Issues XML Plugin:
Fatal error: require_once() [function.require]: Failed opening required 'PubMedExportPlugin.inc.php' (include_path='') in /home/techpubl/public_html/plugins/importexport/pubmed/index.php on line 18

I have a confirmation from hosting service provider that they have disabled ini_set() for security reasons. And now they have enabled it again for my account. But I am still facing above mentioned errors.

Attached is the error_log file from server.

OJS Version 2.4.1.0
OS platform Linux
PHP version 5.3.25
Apache version Apache
Database driver mysql
Database server version 5.1.68-cll

Help is required.
Attachments
error_log.zip
(8.16 KiB) Downloaded 15 times
Farrukh
 
Posts: 8
Joined: Mon Jun 10, 2013 8:32 am

Re: Random errors on OJS

Postby asmecher » Mon Jun 10, 2013 9:14 am

Hi Farrukh,

I see throughout your log:
Code: Select all
Message: WARNING: ini_set() has been disabled for security reasons
I suspect ini_set has not been properly re-enabled on your account.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8419
Joined: Wed Aug 10, 2005 12:56 pm

Re: Random errors on OJS

Postby Farrukh » Mon Jun 10, 2013 9:26 am

Hi Alec,

Just one observation, on any error if I refresh page 2-3 times, it shows the correct contents of the URL.

Seems like some cache is build somewhere and every time OJS returned contents from cache. But in this case refreshing should not result in desired actions.

Any Idea? Should I consider upgrading to the latest version 2.4.2? Would that helps?

Farrukh.
Farrukh
 
Posts: 8
Joined: Mon Jun 10, 2013 8:32 am

Re: Random errors on OJS

Postby asmecher » Mon Jun 10, 2013 10:09 am

Hi Farrukh,

If you're still seeing new "ini_set disabled" messages appear in the log, the problem lies with your hosting provider; each server is configured differently so I can only speculate on the reasons that might be happening intermittently, but I suspect they might be running a pool of PHP processes (e.g. via FastCGI), some of which predate the configuration change. A solution for that would be to restart their PHP process pool.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8419
Joined: Wed Aug 10, 2005 12:56 pm

Re: Random errors on OJS

Postby Farrukh » Tue Jul 02, 2013 6:05 am

Hi Asmecher,

Thank you for your support. My hosting provider enabled ini_set() specifically on my account and the issue is resolved now.

Farrukh.
TechPublications.org
Farrukh
 
Posts: 8
Joined: Mon Jun 10, 2013 8:32 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 4 guests