OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Fatal Error in 2.4.1 to 2.4.2 upgrade

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Fatal Error in 2.4.1 to 2.4.2 upgrade

Postby ThomasBrasdefer » Thu Jun 20, 2013 9:22 am

Hi all,

I have been running OJS pretty successfully since 2.1 and yesterday as I was doing some clean-up of spam accounts and encountered an error causing "merge accounts" to fail (this) so I went back to the site and figured I might as well upgrade to 2.4.2 since the only solution was to do a re-install.

And of course now I cannot successfully complete the process. I am doing the full package upgrade because I do not have bash access. When I press the Upgrade button, after a little while of loading I receive the following error

Code: Select all
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /data/24/2/124/49/2939375/user/3257832/htdocs/ojs/cache/t_compile/%%36^36E^36E89D0E%%header.tpl.php on line 255


I tried emptying the entire cache and did not have much success. I did find this diff but from the look of PKPApplication in 2.4.x it seems those changes have been implemented.

Any idea of how to fix this issue?
ThomasBrasdefer
 
Posts: 4
Joined: Thu Jun 20, 2013 9:09 am

Re: Fatal Error in 2.4.1 to 2.4.2 upgrade

Postby asmecher » Thu Jun 20, 2013 9:35 am

Hi ThomasBrasdefer,

That's 32MB -- quite likely too low a memory limit for the upgrade process. See http://pkp.sfu.ca/wiki/index.php/PKP_Frequently_Asked_Questions#I_am_receiving_the_following_error:_Fatal_error:_Allowed_memory_size_of_8388608_bytes_exhausted_.28etc..29.

If you still hit a limit and more than e.g. 128MB has been allowed, then post back here for other suggestions.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9088
Joined: Wed Aug 10, 2005 12:56 pm

Re: Fatal Error in 2.4.1 to 2.4.2 upgrade

Postby ThomasBrasdefer » Thu Jun 20, 2013 10:02 am

Doh, I thought I had some legroom with the wiki recommending at least 16M.

That solved the issue, thanks!
ThomasBrasdefer
 
Posts: 4
Joined: Thu Jun 20, 2013 9:09 am

Re: Fatal Error in 2.4.1 to 2.4.2 upgrade

Postby asmecher » Thu Jun 20, 2013 10:13 am

Hi ThomasBrasdefer,

I've added a clarification to that part of the FAQ. Glad to hear it's working.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9088
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 6 guests