OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems with quick submit plugin

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Re: Problems with quick submit plugin

Postby Garant » Tue May 14, 2013 10:22 am

Just to make it clearer: the error appears not during the file upload, it appears after when I press the "Save" button (the file should be uploaded before saving)
Garant
 
Posts: 192
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby asmecher » Tue May 14, 2013 10:25 am

Hi Garant,

I understand, but did the change in order not affect the error message?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with quick submit plugin

Postby Garant » Tue May 14, 2013 10:31 am

Hi Alec!
No, it doesn't make any sense :(
Garant
 
Posts: 192
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby Garant » Tue May 28, 2013 2:48 am

Just little update what I've noticed: this bug isn't associated with primary locale. I've tried to swap site primary locale between A and B and added additional C. So it doesn't make any sense when I swaped them... The error still remains :(
Garant
 
Posts: 192
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby asmecher » Mon Jun 03, 2013 4:37 pm

Hi Garant,

Sorry about the delay; I've been tinkering with this but I can't reproduce the problem. I have a journal configured with two languages.

Could you post step-by-step instructions for reproducing the error message?

(Note that I'm using OJS 2.4.2; if I can't reproduce the problem with your instructions, I'll check whether it may just apply to 2.3.x. However, I don't see any changes between the two versions that look suspect.)

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with quick submit plugin

Postby asmecher » Mon Jun 03, 2013 4:39 pm

Hi Garant,

On second thought -- I've just re-read through http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=8169#c8 and that confirms that this is an issue that affects only OJS 2.3.x. I would suggest upgrading to OJS 2.4.2 as it's not affected. We're only releasing security patches for the 2.3.x release line, and 2.4.2 has been marked stable.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with quick submit plugin

Postby Garant » Mon Jun 03, 2013 9:03 pm

Hi, Alec!
I've forgot to mention that we have upgraded to 2.4.2. version.
I will try to record a short video of this issue a bit later.
Thank you!
Garant
 
Posts: 192
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby Garant » Thu Jun 06, 2013 12:28 pm

Hi Alec!
As I promised I've uploaded a short video:
http://youtu.be/sucXo5eS2Fk
It's divided in two parts. The first shows that process doesn't fail. The second approach calls the error.
I've forgot to turn php errors on so at the end you will see the blank page which should contain the error:
Code: Select all
Fatal error: Call to a member function getFileId() on a non-object in /var/www/html/ojs/classes/submission/editor/EditorAction.inc.php on line 123

I hope it will help
Garant
 
Posts: 192
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby asmecher » Thu Jun 06, 2013 2:32 pm

Hi Garant,

Just checking -- when the file is uploaded, the video appears (if I squint) to show 0B for the file size. Is that correct, or could it indicate a failed upload?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with quick submit plugin

Postby Garant » Thu Jun 06, 2013 10:34 pm

Yes, I just have uploaded empty file. As a example. But it doesn't matter. That kind of behaviour was with normal files...
I had small "one sided" "consultation" with another organization. So they indirectly confirmed that the problem also exists with their configuration. But they have changed the default locale to En. I also tried this option but had no luck :(
Maybe it of this that Lithuanian locale is absolutely custom locale and doesn't shipped with OJS package...
Garant
 
Posts: 192
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby asmecher » Mon Jun 10, 2013 11:40 am

Hi Garant,

Thanks to your video, I was finally able to duplicate the problem. See http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=8169#c10 for details including a patch. Thanks for your help.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with quick submit plugin

Postby Garant » Mon Jun 10, 2013 11:45 am

Hi Alec!
Great news!
Thank you for a patch!
I'll try it tomorrow and will write an answer
Garant
 
Posts: 192
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby Garant » Tue Jun 11, 2013 12:46 pm

Hi Alec!
It seems that everything works just fine.
Future work with system will prove it.
Thank you!
P.S. soon I'll post some new proposals :)
Garant
 
Posts: 192
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby asmecher » Tue Jun 11, 2013 1:19 pm

Hi Garant,

Great, thanks for confirming!

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Previous

Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests