OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Cannot login to after moving to new server

General inquiries about the PKP.

Moderators: jmacgreg, btbell, michael, bdgregg, vgabler, barbarah, John

Forum rules
Feel free to post general inquiries about the PKP Here. We'll also post notes of interest from time to time. You may also want to check out the PKP blog.

Cannot login to after moving to new server

Postby donanjana » Tue May 28, 2013 8:26 pm

Hi

I have move OJS from debian 2.4 to centos 6.3. I successfully move the ojs folder and set appropriate permission on the server and also install the database file. After that i tried to login into the system. but it redirect to login page once again. at that time url shows like this

/rjs/index.php/rjs/login?source=%2Frjs%2Findex.php%2Frjs%2Fmanager

At this time i restart the web server. (Pls consider this). Then i tried to log in to the system. then it successfully log in. After log out i tried to log in once again. But it redirect to log in page once again.Then i restart the web server. Then i can log in once again. How can i solve this problem. this not happan to other web folder like squirrel mail on the server.

Anjana
donanjana
 
Posts: 2
Joined: Tue May 28, 2013 8:10 pm

Re: Cannot login to after moving to new server

Postby asmecher » Wed May 29, 2013 8:28 am

Hi Anjana,

This sounds like a problem with session cookies. Try disabling session_check_ip in config.inc.php if it's enabled; also check your error log to see if there's anything relevant there.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Re: Cannot login to after moving to new server

Postby donanjana » Thu May 30, 2013 8:44 am

Hi Alec

I resoled the problem. I disable session_check_ip. I also check apache error log. It show that there is a error called Class 'HookRegistry' not found in lib/pkp/classes/db/DAO.inc.php. I So search on your forum and identify the reason for this. I comment extension=apc.so in apc.ini . Now the system works fine. Thanks for your help

Best Regard
Anjana
donanjana
 
Posts: 2
Joined: Tue May 28, 2013 8:10 pm


Return to General Discussion

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest