OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



artic not accessibile after moving servers and changing urls

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

artic not accessibile after moving servers and changing urls

Postby dcomeaux » Thu May 16, 2013 9:18 am

Hi,

I was asked to move our installation to a different server, and to change the url from ojs.tulane.edu to library.tulane.edu/ojs. I have moved the files and database to the new server. Most everything seems to work, accept the articles are not displaying, nor can they be downloaded. I've changed the file permissions on the files, cache, public and js directories to 775 (which was working on the original server). I also changed the base url and path to the files directory in the config.inc.php file. I'm still not able to see the articles. I've searched the forum archive and I don't see another post that discusses a problem exactly like mine.

Can you help please?

Respectfully,
Dave
dcomeaux
 
Posts: 17
Joined: Sat Jan 19, 2013 3:22 pm

Re: artic not accessibile after moving servers and changing

Postby asmecher » Thu May 16, 2013 9:23 am

Hi Dave,

There may still be file permissions problems -- who owns the files in your files_dir?

Is the new server using SELinux? If so, there may be additional security settings to tweak.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: artic not accessibile after moving servers and changing

Postby dcomeaux » Fri May 17, 2013 12:31 pm

Hi Alec,

Thanks for your quick response! I'm still awaiting a response from our system admin about the information you requested. I'll get back to you as soon as I have it.

Thanks again,
Dave
dcomeaux
 
Posts: 17
Joined: Sat Jan 19, 2013 3:22 pm

Re: artic not accessibile after moving servers and changing

Postby dcomeaux » Tue May 21, 2013 10:29 am

Hi Alec,

i talked to our server administrator, and it turns our that the path I had to the files directory was wrong. He put the correct path in the config file for me and everything looks good now!

Thanks for your assistance!
Dave
dcomeaux
 
Posts: 17
Joined: Sat Jan 19, 2013 3:22 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests