OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



RSS feed Plugin Problem

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

RSS feed Plugin Problem

Postby janer » Mon May 13, 2013 7:21 am

Hello,

I have just enabled this Web Feed Plugin, and have asked for it to appear on the Home Page and issue page only - just the current issue - as we want to link to the list of contents. No icons have appeared in the sidebar, but in the Internet Explorer bar at the ehad of the screen, the RSS logo is coloured orange on hte Home page, but not elsewhere. However, when I click it this is what I get:

Internet Explorer cannot display this feed
This feed contains code errors.
Go back to the previous page.
More information
The following tags were not closed: feed.
Line: 0 Character: 0


Can you tell me please what has gone wrong?

Many thanks,

Janer
janer
 
Posts: 136
Joined: Fri May 16, 2008 7:12 am

Re: RSS feed Plugin Problem

Postby asmecher » Mon May 13, 2013 9:28 am

Hi Janer,

Can you post a link to your RSS feed here? Alternately, take a look at the source code that OJS serves up when you follow the RSS link. I suspect there's an error message or something similar in the mark-up.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8609
Joined: Wed Aug 10, 2005 12:56 pm

Re: RSS feed Plugin Problem

Postby janer » Wed May 15, 2013 4:42 am

Hi Alex,

Do you mean this? http://ojs26.llcsjournal.org/index.php/ ... lugin/atom

Sorry I am not a technical person so I don't know how to do any source code stuff - this is just what happens if I click the RSS link. i should tell you that this is on a test website and not our main one!

Hope this helps solve the problem.

Thanks

Janer
janer
 
Posts: 136
Joined: Fri May 16, 2008 7:12 am

Re: RSS feed Plugin Problem

Postby asmecher » Wed May 15, 2013 8:37 am

Hi Janer,

Yes, there's an error message if you view the mark-up:
Code: Select all
<b>Fatal error</b>:  Call to undefined method PublishedArticle::getDateModified() in <b>E:\htdocs\LLCS26\cache\t_compile\%%4A^4A7^4A718C1B%%atom.tpl.php</b> on line <b>24</b><br />
This is a known issue in OJS 2.3.6; see bug #6729, referenced here.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8609
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 3 guests