OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



CrossRef XML Export Plugin Missing <publication_date> tag

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

CrossRef XML Export Plugin Missing <publication_date> tag

Postby thebigaym » Thu Apr 05, 2012 4:29 pm

As journal manager

Home > User > Journal Management > Import/Export Data

CrossRef XML Export Plugin: Export article metadata in CrossRef XML format.

I was using this tool to export older issues to submit them to CrossRef for DOI assignment.

At the article level, the <publication_date> tag was missing.

<publication_date media_type="online"><month>05</month><day>05</day><year>2007</year></publication_date>

I had to go into each article through Editor Role

Home > User > Editor > Issues > Vol 39, No 4

and add a publication date to the "Editing" tab of each article.

Would somebody modify this plugin to default to the issue publication date if an article is missing a publication date?
thebigaym
 
Posts: 46
Joined: Thu Apr 09, 2009 8:25 am

Re: CrossRef XML Export Plugin Missing <publication_date> ta

Postby jmacgreg » Thu Apr 19, 2012 10:08 pm

Hi Thebigaym,

Thanks for your report -- we've had another report of this potentially being a problem, at the end of http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=7026. I've reopened that bug and will investigate further. Please feel free to CC yourself to that report for future updates.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: CrossRef XML Export Plugin Missing <publication_date> ta

Postby vgabler » Tue Apr 23, 2013 11:50 am

Hi, All,

It seems like there might be a couple of different threads on this subject and some bug reports. I've been doing some investigation from the perspective of a Journal Manager/Editor, whereas we a Web developer in our office who has been approaching this from a code standpoint. This is what my testing has produced.

I went through an issue I published today to try to match up the recorded publication dates with action dates in the history of each article record. Here’s what I found:

#72 publication date 3/24/2013. Same day, review assignment canceled
#82 publication date 3/3/13. Date submitted and editor assigned
#69 publication date 11/30/12. Date editor assigned
#73 publication date 3/24/13. No match
#74 publication date 2/24/13. No match

I believe that the setting of the publication date is most likely tied to when an article is assigned to an issue in the Editing page of an individual article record. It appears as though the publication date that is being set is what the date is at the time an article is assigned in the Editing page of an individual article (this action does not seem to be tracked in the history, so I can’t verify it).

This would seem to tie into the problem we are having when an issue publication date appears as null. I submitted articles with the QuickSubmit plugin on two sites. In both instances, I assigned an article to an issue while completing the QuickSubmit plugin and never in the individual article record on the Editing page. In both instances, the publication date then appeared as null on the Editing page of the article record and in the CrossRef export.

It seems to me that the action setting the publication date is associated with assigning an article to an issue in the article record. How the feature should work is that the timestamp when an issue is published becomes the default publication date everywhere. Then, editors can use the dropdown menu in the Issue Data section to override the publication date for an issue (which would trickle down to all article records) when necessary. In the case where various articles need to have different publication dates within an issue (such as the "publish as you go" journals), that publication date can be overridden in the individual article record's Editing page.

We'll continue to look into this issue here. It would be helpful to us if the person(s) who developed this new feature could point us to the commit file on the github (boy I hope I remembered to say that right) so that we know where to start our efforts.

If you have any questions please feel free to ask!

All best,
Vanessa Gabler
vgabler
 
Posts: 95
Joined: Thu Feb 18, 2010 1:22 pm

Re: CrossRef XML Export Plugin Missing <publication_date> ta

Postby RobinTaylor » Wed Sep 04, 2013 6:33 am

Hi all,

We have also encountered this problem generating files for Crossref and I thought it worth documenting. I generated a test XML file and ran it through their XML validator, it complained that there were no publications dates at a journal article level. However, the Crossref documentation states that this element is optional (see page 99 here http://www.crossref.org/schema/info/Cro ... 04.1.0.pdf). I realise the documentation is for 4.1.0 rather than 4.3.0 but its the best I could find. In addition my reading of the XSD is that it is meant to be optional :-

<xsd:complexType>
<xsd:sequence>
<xsd:element ref="titles" minOccurs="0"/>
<xsd:element ref="contributors" minOccurs="0"/>
<xsd:element ref="publication_date" minOccurs="0"/>
<xsd:element ref="description" minOccurs="0"/>
<xsd:element ref="format" minOccurs="0"/>
<xsd:element ref="doi_data"/>
</xsd:sequence>

So I don't know why the validator insists on it being present, I suspect the XSD is not quite right. I'll report this to Crossref but in the meantime I guess we have to investigate generating publication dates at article level.

Cheers, Robin.
RobinTaylor
 
Posts: 3
Joined: Fri Mar 06, 2009 6:26 am

Re: CrossRef XML Export Plugin Missing <publication_date> ta

Postby RobinTaylor » Wed Sep 04, 2013 8:34 am

Hi again,

Just adding an update to my previous post. In contradiction to the documentation Crossref have replied that the publication date is required at journal_article level. This was their reply...

"Hi Robin,

The publication date is required for journal issue and article level DOIs. The list of required elements is available here:

http://help.crossref.org/#elements
http://help.crossref.org/#deposit_fees

In the PDF document, under publication_date, the comments are as follow:
Required in journal_issue, journal_article, proceedings_metadata, conference_paper, book_metadata, content_item.

Let me know if you need any additional information.

Regards,
Vaishali"

Cheers, Robin.
RobinTaylor
 
Posts: 3
Joined: Fri Mar 06, 2009 6:26 am


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest