OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS upgrade failed, DB error?!

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

OJS upgrade failed, DB error?!

Postby yhan » Tue Apr 16, 2013 5:46 pm

Hi! I am trying to upgrade from 2.3.7 to 2.4.2.

I have followed the recommendation using "patch -p1 --dry-run <ojs-2.3.7_to_2.4.2.patch" which generates no error.

After patching it, the webpage has certain journals showing "DB Error: Table 'ojs.issue_galleys' doesn't exist". So I assume that the patch is trying to update database and probably failed. I believe that I have correct database login/password in "config.inc.php".

Anyone can help? Why is the update to the OJS database failed?
yhan
 
Posts: 30
Joined: Thu Mar 08, 2012 1:57 pm

Re: OJS upgrade failed, DB error?!

Postby asmecher » Wed Apr 17, 2013 10:03 am

Hi yhan,

See docs/UPGRADE. There are two parts to the upgrade process: upgrading the code, and upgrading the database. The patch only addresses the first part.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: OJS upgrade failed, DB error?!

Postby anujmittal » Tue Mar 17, 2015 4:08 am

Sir I
upgraded OJS 2.3 to 2.5 and Now my article are failed to download and they are now showing anything.

please help me.

my website link is http://thepharmaresearch.info/ojs/index ... QgKYtKUd1Z

login id : [removed]
password: [removed]


please help me out.
anujmittal
 
Posts: 2
Joined: Tue Mar 17, 2015 4:00 am

Re: OJS upgrade failed, DB error?!

Postby asmecher » Tue Mar 17, 2015 7:59 am

Hi anujmittal,

Check your new version -- there is no version 2.5.

Please don't post passwords here; it's not safe.

Check the files_dir setting in your config.inc.php to make sure that it's the same as in your old config.inc.php file.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: OJS upgrade failed, DB error?!

Postby anujmittal » Tue Mar 17, 2015 9:21 pm

Thank you sir, I have done that.
anujmittal
 
Posts: 2
Joined: Tue Mar 17, 2015 4:00 am


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests