OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



New User Mail

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

New User Mail

Postby cchavezPKP » Tue Apr 16, 2013 5:16 pm

Hi everyone, I recently installed OJS in my server, the system is working OK, but I am having trouble with mails, i tested the email module and send it from my OJS system, it works fine, but when I add a new user and try to send the "welcome" email when I create the it , the system creates the user but the mail is not sent, further there are in the log file the following entries:

[Tue Apr 16 19:01:52 2013] [error] [client xxx.xx.xx.xxx] OJS SMTPMailer: Did not receive expected 250 or 251, referer: http://mysitexx/ojs2/index.php/myjourna ... updateUser

And these warnings:

- WARNING: array_unique() expects parameter 1 to be array, null given\n In file: /var/www/ojs2/lib/pkp/classes/user/InterestDAO.inc.php at line.............

- WARNING: array_map(): Argument #2 should be an array\n In file: /var/www/ojs2/lib/pkp/classes/user/InterestDAO.inc.php\n At Line ...........

So, What am I missing here, does anybody have an idea what i am doing wrong?

Thanks for your help by the way.
cchavezPKP
 
Posts: 3
Joined: Tue Apr 16, 2013 4:36 pm

Re: New User Mail

Postby asmecher » Tue Apr 16, 2013 5:21 pm

Hi cchavezPKP,

The warnings are cosmetic and you can ignore them. The error message suggests that there was trouble using your SMTP credentials to send the email; double-check your SMTP configuration in config.inc.php.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Re: New User Mail

Postby cchavezPKP » Tue Apr 16, 2013 5:40 pm

Thank you Alec, but i have tested it, i have sent an email trough OJS to the same user using the "Request" button.
Since i haven't seen the "Welcome Mail" format yet, maybe i guess it could be that my SMTP server doesn't allow something that is sent in that mail, could that be the reason? maybe?.

Thanks again Alec.
cchavezPKP
 
Posts: 3
Joined: Tue Apr 16, 2013 4:36 pm

Re: New User Mail

Postby cchavezPKP » Tue Apr 16, 2013 5:55 pm

I have tested with GMAIL SMTP the new user mail works OK, thanks Alec it seems that the SMTP server doesn't work correctly.

Case closed.
cchavezPKP
 
Posts: 3
Joined: Tue Apr 16, 2013 4:36 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 4 guests