OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



upgrade problem

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

upgrade problem

Postby agentsmith » Fri Sep 15, 2006 4:54 pm

I am trying to upgrade from 2.0.1 (at least that is what it says in the docs/release-notes) to 2.1 but when i try the manual upgrade i get DB Error: Table 'ojs.article_search_object_keywords' doesn't exist. Is it possible that the version I am currently using isn't really 2.0.1 is there anyway i can know for sure? Has anybody else had this problem?

Thanks
J
agentsmith
 
Posts: 36
Joined: Fri Sep 15, 2006 4:40 pm

Postby asmecher » Sat Sep 16, 2006 1:51 am

Hi J,

Upgrading is a two-step process; the first step is upgrading the code, and the second step is upgrading the database. It sounds to me like you haven't completed the second step. Try using the tools/upgrade.php script as follows (after backing everything up, of course):
Code: Select all
php tools/upgrade.php upgrade
Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm

Postby agentsmith » Mon Sep 18, 2006 12:03 pm

thanks,

i tried to do an upgrade with what you suggested and got this:

$ php tools/upgrade.php upgrade

[load: upgrade.xml]
[version: 2.1.1.0]
[data: upgrade/2.0.2_preupdate.xml]

ERROR: Upgrade failed: DB: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

I get the same error when upgrading use the automatic button of the web interface.
I have tried it with both mysql 5.0 and 4.1.1
agentsmith
 
Posts: 36
Joined: Fri Sep 15, 2006 4:40 pm

Postby asmecher » Tue Sep 19, 2006 4:40 am

Hi J,

This is probably caused by a failed attempt to upgrade. You can get around it by commenting out the following lines in dbscripts/xml/upgrade/2.0.2_preupdate.xml:
Code: Select all
        <sql>
                <rename table="subscription_types" column="public" to="pub" />
        </sql>
However, if the previous upgrade attempt only partially completed, you may have other similar problems. The best way to ensure a clean upgrade is to start from your pre-upgrade backup and try again, reporting error messages here.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 5 guests