OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems with quick submit plugin

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Problems with quick submit plugin

Postby rosagabriela » Mon May 30, 2011 11:04 am

Hello,

I use version 2.3.4 of OJS, and I'm trying to publish the first articles by using the quick submit plugin, but when I click the "save" button, I get the following message: "Fatal error: Call to a member function getFileId() on a non-object in /web/periodicos/classes/submission/editor/EditorAction.inc.php on line 124". What does it mean?

Thanks,
Gabriela Rosa de Abreu

P.S.: Please forgive me if there is something wrong with the English, cause I'm from Brazil...
rosagabriela
 
Posts: 1
Joined: Mon Apr 25, 2011 1:16 pm

Re: Problems with quick submit plugin

Postby mcrider » Tue Jun 14, 2011 10:50 am

Hi Gabriela,

Can you turn on stack traces as per these instructions on our wiki?

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Problems with quick submit plugin

Postby Garant » Fri Feb 08, 2013 7:28 am

Hello!
I've configured few additional journals and have tried to publish some journals through the quickSubmit plugin.
After pressing "Save" button I see blank screen. The article goes to editing without assigned issue (I'm selecting the current issue in plugin).
Here is the error log:
Code: Select all
[Thu Feb 07 11:30:07 2013] [error] [client xx.xxx.xx.xx] PHP Fatal error:  Call to a
member function getFileId() on a non-object in
/var/www/html/ojs/classes/submission/editor/EditorAction.inc.php on line 124,
referer: https://www.site.com/ojs/journal/manager/importexport/plugin/QuickSubmitPlugin
[Thu Feb 07 11:31:22 2013] [error] [client yy.yyy.yy.yyy] CAUGHT EXCEPTION:
Assigning the return value of new by reference is deprecated
(/var/www/html/ojs/plugins/blocks/popularArticles/PopularArticlesBlockPlugin.inc.php:27)
[Thu Feb 07 11:32:53 2013] [error] [client yy.yyy.yy.yyy] CAUGHT EXCEPTION:
Assigning the return value of new by reference is deprecated
(/var/www/html/ojs/plugins/blocks/popularArticles/PopularArticlesBlockPlugin.inc.php:27)
[Thu Feb 07 11:36:21 2013] [error] [client yy.yyy.yy.yyy] CAUGHT EXCEPTION:
Assigning the return value of new by reference is deprecated
(/var/www/html/ojs/plugins/blocks/popularArticles/PopularArticlesBlockPlugin.inc.php:27)
[Thu Feb 07 11:41:18 2013] [error] [client yy.yyy.yy.yyy] CAUGHT EXCEPTION:
Assigning the return value of new by reference is deprecated
(/var/www/html/ojs/plugins/blocks/popularArticles/PopularArticlesBlockPlugin.inc.php:27)
[Thu Feb 07 11:46:14 2013] [error] [client yy.yyy.yy.yyy] CAUGHT EXCEPTION:
Assigning the return value of new by reference is deprecated
(/var/www/html/ojs/plugins/blocks/popularArticles/PopularArticlesBlockPlugin.inc.php:27)
[Thu Feb 07 11:46:39 2013] [error] [client xx.xxx.xx.xx] PHP Fatal error:  Call to a
member function getFileId() on a non-object in
/var/www/html/ojs/classes/submission/editor/EditorAction.inc.php on line 124,
referer: https://www.site.com/ojs/journal/manager/importexport/plugin/QuickSubmitPlugin
[Thu Feb 07 11:50:05 2013] [error] [client xx.xxx.xx.xx] PHP Fatal error:  Call to a
member function getFileId() on a non-object in
/var/www/html/ojs/classes/submission/editor/EditorAction.inc.php on line 124,
referer: https://www.site.com/ojs/journal/manager/importexport/plugin/QuickSubmitPlugin
[Thu Feb 07 11:50:40 2013] [error] [client zz.zzz.zz.zzz] File does not exist:
/var/www/html/favicon.ico
[Thu Feb 07 11:50:40 2013] [error] [client zz.zzz.zz.zzz] File does not exist:
/var/www/html/favicon.ico
[Thu Feb 07 11:51:06 2013] [error] [client yy.yyy.yy.yyy] CAUGHT EXCEPTION:
Assigning the return value of new by reference is deprecated
(/var/www/html/ojs/plugins/blocks/popularArticles/PopularArticlesBlockPlugin.inc.php:27)
[Thu Feb 07 11:53:55 2013] [error] [client xx.xxx.xx.xx] PHP Fatal error:  Call to a
member function getFileId() on a non-object in
/var/www/html/ojs/classes/submission/editor/EditorAction.inc.php on line 124,


Is it a bug?
Garant
 
Posts: 195
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby JasonNugent » Fri Feb 08, 2013 2:10 pm

Hi Garant,

What version of OJS are you using?

Cheers,
Jason
JasonNugent
Site Admin
 
Posts: 791
Joined: Tue Jan 10, 2006 6:20 am

Re: Problems with quick submit plugin

Postby Garant » Sat Feb 09, 2013 12:55 am

JasonNugent wrote:Hi Garant,

What version of OJS are you using?

Cheers,
Jason

Hi!
I'm running the 2.3.8.0 version.
P.S. With the first configured, main journal this plugin worked perfectly. Only one time I discovered that bug... But with others recently configured journals it is permanent :(
Garant
 
Posts: 195
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby Garant » Thu Mar 14, 2013 9:51 am

Hi!
Today is my bug hunt day :-)
I found the problem!
It is associated with additional languages.
The journals supports two languages; A and B
When using plugin in the Form Language the primary selected language is A(it is not system's default language).
So if I upload submission file when language A is selected and I haven't uploaded a file with changed Form Language to B - I receive those errors. (So, only one file must be attached)
But if upload submission with selected language B - everything work as a charm.
So, here is a small bug which should be fixed :)
Garant
 
Posts: 195
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby Garant » Fri Apr 12, 2013 4:07 am

Don't want to create another thread so I will post my enhancement vision here:
It would be nice to have an AJAX autocomplete feature to be enabled filling author details.
The jQuery framework is enabled by default so there isn't much problems except writing the plugin :)
When it could be useful: When submitting articles and filling author details autocomplete feature could provide pre selected choice with authors data (if several letters/? concur) from earlier filled entries in DB.
Garant
 
Posts: 195
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby asmecher » Fri Apr 12, 2013 8:49 am

Hi Garant,

Agreed; we're making a lot of UI changes in the master branch (for release in OJS 3.0), which will look quite different from past releases and will allow us to easily add this kind of helper.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7746
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with quick submit plugin

Postby Garant » Fri Apr 12, 2013 8:55 am

HI, Alec!
Great news!!!
Garant
 
Posts: 195
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby Garant » Tue May 14, 2013 6:34 am

Hi!
Having problems with PKP Bugzilla, doesn't accept my login...
So I've just updated OJS till 2.4.2 version and problem which I've described here:
http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=8169#c8
still remain.
The error code which I receive is:
Code: Select all
Fatal error: Call to a member function getFileId() on a non-object in /var/www/html/ojs/classes/submission/editor/EditorAction.inc.php on line 123

I hope the problem will be solved.
Garant
 
Posts: 195
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby asmecher » Tue May 14, 2013 8:38 am

Hi Garant,

Have you run through the quick submit process without using the language pulldown? If so, does that work?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7746
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with quick submit plugin

Postby Garant » Tue May 14, 2013 8:42 am

HI, Alec!
As our journals are published in two languages I always fill two forms for two languages through the quick submit process
Garant
 
Posts: 195
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby asmecher » Tue May 14, 2013 9:06 am

Hi Garant,

Can you try varying the order of submission, i.e. if you saw the error when you first uploaded the file then changed the language, try entering both languages first then uploading the file.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7746
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with quick submit plugin

Postby Garant » Tue May 14, 2013 9:15 am

Hi, Alec!
I've tried to fill meta info in both languages without uploading the file. The test article have appeared without error in the selected issue
Garant
 
Posts: 195
Joined: Wed May 30, 2012 8:53 am

Re: Problems with quick submit plugin

Postby asmecher » Tue May 14, 2013 9:20 am

Hi Garant,

How about a different order of submission? Try both:
  • Upload the file; then enter the metadata in both languages, using the pulldown
  • Enter the metadata in both languages using the pulldown, then upload the file
Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7746
Joined: Wed Aug 10, 2005 12:56 pm

Next

Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron