OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Google Analytics plugin

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Google Analytics plugin

Postby feeldesign » Sat Mar 02, 2013 4:44 am

After upgrading to a newer version The Google analytics plugin was disabled. I re-enabled, and when I went to settings I got the following message
Invalid management action on disabled plug-in!

I can't find a new version to upgrade to - anyone know where it is, it's not in the forums plugins, and Googling it can't produce any results that show it.
Any help appreciated

James
feeldesign
 
Posts: 2
Joined: Thu May 10, 2012 2:59 am

Re: Google Analytics plugin

Postby michael » Wed Mar 06, 2013 5:38 pm

Hi James,

Which version of OJS did you upgrade from/to?

Thanks,
Michael
michael
 
Posts: 404
Joined: Thu Mar 29, 2007 2:09 pm

Re: Google Analytics plugin

Postby feeldesign » Tue Mar 19, 2013 12:41 pm

Hi
Sorry - only just saw the response as your forum didnt notify me.
We upgraded from 2.3.6 to 2.3.8

Is there a new version of the plugin that works?

Thanks
James
feeldesign
 
Posts: 2
Joined: Thu May 10, 2012 2:59 am

Re: Google Analytics plugin

Postby michael » Tue Mar 19, 2013 5:04 pm

Hi James,

The GA plugin has not changed since OJS 2.3.6 and should continue to work as before without any needed changes.

As Site Administrator, can you please try clearing your data cache:
User Home => Site Administrator => Clear Data Caches

Then as Journal Manager, try accessing the plugin settings again.

You can also double-check that the GA plugin is correctly enabled by looking at your database directly.

The following MySQL query,
Code: Select all
SELECT * FROM plugin_settings WHERE plugin_name = 'googleanalyticsplugin';

should include a setting value of 1 for the 'enabled' setting name, i.e.

Code: Select all
+-----------------------+--------+------------+--------------+---------------+--------------+
| plugin_name           | locale | journal_id | setting_name | setting_value | setting_type |
+-----------------------+--------+------------+--------------+---------------+--------------+
| googleanalyticsplugin |        |          1 | enabled      | 1             | bool         |
+-----------------------+--------+------------+--------------+---------------+--------------+

Cheers,
Michael
michael
 
Posts: 404
Joined: Thu Mar 29, 2007 2:09 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 5 guests