OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Strange Fault Error On Attempt to Publish to OJS

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Strange Fault Error On Attempt to Publish to OJS

Postby ojshelpatucalgary » Fri Feb 08, 2013 6:43 pm

We are experiencing a strange error being thrown when attempting to publish an issue to a journal that had been working fine in this regard.
The only change that has been made recently is the IP address and DNS settings to the VM where the journal is hosted.
What's most weird is the error references java and WIN.

Array ( [faultcode] => soapenv:Server.userException [faultstring] => java.lang.StringIndexOutOfBoundsException: String index out of range: -4 [detail] => Array ( [hostname] => WIN-NNDXTZZKCBH ) )
Fault

Could this be coming from something external to OJS, like Apache?

Thanks for any help to figure this out.
ojshelpatucalgary
 
Posts: 10
Joined: Fri Feb 08, 2013 4:14 pm
Location: Calgary

Re: Strange Fault Error On Attempt to Publish to OJS

Postby asmecher » Fri Feb 22, 2013 5:41 pm

Hi ojshelpatucalgary,

Sorry, I'm not sure where that's coming from -- but it's definitely not OJS.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9208
Joined: Wed Aug 10, 2005 12:56 pm

Re: Strange Fault Error On Attempt to Publish to OJS

Postby ojshelpatucalgary » Fri Feb 22, 2013 7:58 pm

I should have mentioned here that we figured out that it was a problem with our PID PlugIn connection to our handle server and generating PID's.
Nothing to do with OJS itself. It's been sorted out now.

Thanks!
ojshelpatucalgary
 
Posts: 10
Joined: Fri Feb 08, 2013 4:14 pm
Location: Calgary


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 2 guests