OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Initial login page takes data, but remains the same

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Re: Initial login page takes data, but remains the same

Postby Kavitamin » Sat Oct 27, 2012 2:30 am

removed post
Last edited by Kavitamin on Sun Oct 28, 2012 7:59 am, edited 1 time in total.
Kavitamin
 
Posts: 9
Joined: Fri Oct 12, 2012 9:47 am

Re: Initial login page takes data, but remains the same

Postby asmecher » Sat Oct 27, 2012 1:42 pm

Hi Kav,

Change your web host password immediately -- you posted your database account information in this post, which is potentially the same for your hosting account in general. Please don't post passwords here.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: Initial login page takes data, but remains the same

Postby Kavitamin » Sun Oct 28, 2012 8:00 am

Thanks for that Alec,

Passwords all changed.

Kav
Kavitamin
 
Posts: 9
Joined: Fri Oct 12, 2012 9:47 am

Re: Initial login page takes data, but remains the same

Postby asmecher » Sun Oct 28, 2012 8:46 am

Hi Kav,

Are you using any kind of mod_rewrite setup? I'd suggest checking the cookie that OJS sends to see what path it uses; if that path doesn't match the URL to OJS, then perhaps that's the problem. (Instructions for this vary by browser, but try googling e.g. "inspecting cookies firefox".) The cookie should be called OJSSID.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: Initial login page takes data, but remains the same

Postby Kavitamin » Fri Nov 09, 2012 5:20 am

Dear Alec,

I have used firebug, and the cookies set are: OJSSID=e07345f8a687e60519eee37003cb20d9; path=/ojs-2.3.7 2/

I don't understand the last post about mod rewrite? I'm not too sure where to go with this now? Anymore suggestions?

Regards

Kavit
Kavitamin
 
Posts: 9
Joined: Fri Oct 12, 2012 9:47 am

Re: Initial login page takes data, but remains the same

Postby asmecher » Fri Nov 09, 2012 10:01 am

Hi Kavit,

The problem is that space in the cookie path. I'd suggest moving your installation so that the directory it's in doesn't contain a space.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: Initial login page takes data, but remains the same

Postby Kavitamin » Sun Nov 11, 2012 5:02 pm

Dear Alec for getting back to me. As a novice i need to clarify exactly what that means. Do i need to re-install everything? The journal is pretty much up on website, will i lose all my settings? Or is this something i can do in my files manager on my web server?

Regards,

Kav
Kavitamin
 
Posts: 9
Joined: Fri Oct 12, 2012 9:47 am

Re: Initial login page takes data, but remains the same

Postby asmecher » Sun Nov 11, 2012 6:58 pm

Hi Kavit,

You can just rename the directory OJS is installed in; then review your settings in Journal Setup and change any URLs containing the old path to refer to the new one. (There should only be 2 or 3 of these, depending on what settings you've customized.)

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7717
Joined: Wed Aug 10, 2005 12:56 pm

Re: Initial login page takes data, but remains the same

Postby ljegou » Thu Jan 24, 2013 6:30 am

Hello, i have the same problem : just after fresh install of stable 2.3.8 version, i can't login as admin, the page reloads to the login page.
I've tried to login many times, it worked one time only.

OJS is installed in a directory of the web root : /ojs/, i've an .htacces with the rewrite rules.
The Apache log shows many errors of the type : "client denied by server configuration: /home/htdocs/index" (/home/htdocs is the web root path).

Here is the Apache configuration for the /ojs/ directory :

<Directory "/home/htdocs/ojs">
AllowOverride All
Options Indexes FollowSymlinks
Order allow,deny
Allow from all
</Directory>


I've checked all ideas i've found in the FAQ and here, to no avail.

The browsers are accepting cookies (and they seems ok, with the real path). I've set the session_check_ip to Off

I've activated the MySQL debug option of the config.inc.php, it seems that the login is accepted then rejected ?

Thanks for your help :)

Edit : Same pb. with 2.4.1

Edit2 : More info. on the pb. With firebug i looked at the OJSSID cookie, and then at the sessions table. There i found that on the record corresponding to the sessions cookie value, the user_id field was 0, instead of 1 (admin user). When i change that value to 1, i'm recognized as the admin by the site. Not sure if it helps, perhaps the login process can't recognize my credentials ?
ljegou
 
Posts: 2
Joined: Thu Jan 24, 2013 6:21 am

Re: Initial login page takes data, but remains the same

Postby ljegou » Fri Jan 25, 2013 2:50 am

Another info : after a server restart, the first login is always ok, the following logins always erroneous.
ljegou
 
Posts: 2
Joined: Thu Jan 24, 2013 6:21 am

Previous

Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 5 guests