OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



DataCite DOI plugin blocker error

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

DataCite DOI plugin blocker error

Postby marchitelli » Thu Jan 10, 2013 1:05 am

Hi,
since yesterday we verified that DataCite DOI registration is not working.

MDS API get an error saying "412 Precondition failed - metadata must be uploaded first". I think that the explication is that, until January 7 you could create DOIs before (or whitout) sending metadata too, but now you must to create DOIs only after uploading metadata for the article.

Note that MDS documentation ever stated that you have to send metadata with the DOI create request, but you still create DOIS with any metadata.
Now the API works only as described in the docs.

Another question :)
When I register articles, I ever get "is Ref Quality = false".
Do you know why?

Cheers,
Andrea
marchitelli
 
Posts: 121
Joined: Tue May 22, 2007 12:44 am

Re: DataCite DOI plugin blocker error

Postby jerico » Mon Jan 21, 2013 10:37 am

Hi Andrea,

we are aware of the problem. It is due to an API change on the side of Datacite that was announced some time ago but we didn't know about it. Sorry!

A bug fix will be released within the next days.

Florian
jerico
 
Posts: 94
Joined: Sat May 16, 2009 2:45 pm

Re: DataCite DOI plugin blocker error

Postby jerico » Tue Jan 22, 2013 5:49 am

I just made a pull request with the patch. As soon as the pull request has been accepted by PKP, you'll be notified with a link to the patch.
jerico
 
Posts: 94
Joined: Sat May 16, 2009 2:45 pm

Re: DataCite DOI plugin blocker error

Postby AlessandroPierno » Thu Nov 06, 2014 5:44 am

Hello,
we verified that DataCite DOI Plug in registration now is not working.

This is notification: "Notification. Registration was not successful! The DOI registration server returned an error: 'No response from server.'.".
Can someone give me some advice on this?

Thank you!
alessandro
AlessandroPierno
 
Posts: 3
Joined: Thu Nov 06, 2014 5:24 am

Re: DataCite DOI plugin blocker error

Postby marchitelli » Thu Nov 06, 2014 6:29 am

Hi,
I just received this message from Datacite

Due to the recent POODLE vulnerability (see e.g.
https://en.wikipedia.org/wiki/POODLE) we have disabled support for SSL
3.0 in all our service using https. We support only TLS 1, 1.0 and 1.1
by now.

This is not a problem for browser usage - if your browser is not older
than say 8 years. However we are notified that some MDS API clients are
using SSL3 explicitly.

One of them is Open Journal System (OJS). We already informed them
(https://github.com/pkp/ojs/pull/340) and the fix will be included in
the next OJS version 2.4.5 as far as I understand. As the fix is only
about removing a single line of code you could apply it on your own. See
the above github link for details.

Best
Sebastian
DataCite Tech Team Lead
marchitelli
 
Posts: 121
Joined: Tue May 22, 2007 12:44 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 3 guests