You are viewing the PKP Support Forum | PKP Home Wiki

WARNING: strtotime()

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

WARNING: strtotime()

Postby linredec » Wed Jan 16, 2013 7:33 am

I found that
this viewtopic.php?f=8&t=2163&hilit=WARNING%3A+strtotime
this viewtopic.php?f=8&t=469&hilit=WARNING%3A+strtotime
doesn't look like my error, so seems like different case. Plus those two are kinda old.

Running ojs 2.3.6, and trying to run this ../tools/runScheruledTasks.php file. At first everything was ok, until one day i started to receive emails from system, that there's an error. It was configured in Cron to run this file every 5min.

error looks like this, just repeats nine times. What may be wrong? System didn't have anything major changed at the time this started to happen.

Code: Select all
ojs2 has produced an error
  Message: WARNING: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead
  In file: /usr/home/ojs/public_html/lib/pkp/classes/scheduledTask/ScheduledTaskDAO.inc.php
  At line: 38
  Server info:
   OS: FreeBSD
   PHP Version: 5.3.10
   Apache Version: N/A
   DB Driver: mysql
   DB server version: 5.5.20
Posts: 2
Joined: Wed Jan 16, 2013 5:45 am

Re: WARNING: strtotime()

Postby asmecher » Wed Jan 16, 2013 10:33 am

Hi linredec,

To suppress this message, you need to set the date.timezone setting in your php.ini. See http://php.net/manual/en/datetime.configuration.php for details. (The warning is cosmetic, i.e. it hasn't stopped your cron job from running, it's just made it noisier.)

Alec Smecher
Public Knowledge Project Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: WARNING: strtotime()

Postby linredec » Thu Jan 17, 2013 2:04 am

And it worked!
Thank you very much : )
Posts: 2
Joined: Wed Jan 16, 2013 5:45 am

Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests