OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



proofreading - author error message

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

proofreading - author error message

Postby Kate L. » Wed Aug 02, 2006 3:00 pm

Hi there

I am close to finalising our first issue using your software. I have encountered the following problem. With one article, a galley proof has been loaded and the author asked to check the proofs. However he cannot click on 'complete'. I have logged in as the author and when I click on 'complete' I get the following message:

[quote]Fatal error: Call to a member function on a non-object in /law/maritimejournal/journal/classes/submission/proofreader/ProofreaderAction.inc.php on line 134[/quote]

can you help by telling me how to fix this?

Many thanks

Kate
Kate L.
 
Posts: 5
Joined: Tue Apr 11, 2006 11:25 pm

Postby asmecher » Wed Aug 02, 2006 4:09 pm

Hi Kate,

Which version of OJS are you running? (You can check by looking at dbscripts/xml/version.xml.)

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9076
Joined: Wed Aug 10, 2005 12:56 pm

Postby Kate L. » Thu Aug 03, 2006 6:53 pm

Hi Alec

My IT guy tells me that we are running version 2.1.0.

Cheers

Kate
Kate L.
 
Posts: 5
Joined: Tue Apr 11, 2006 11:25 pm

Postby asmecher » Thu Aug 03, 2006 7:13 pm

Hi Kate,

Can you check if the submission has been assigned to an editor? You'll see the assigned editors listed on the submission's Summary page (which you can access as Editor or Section Editor). The submission must be assigned to at least one editor. (Of course, you shouldn't be receiving an error message in a situation like this -- I'll look into it.)

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9076
Joined: Wed Aug 10, 2005 12:56 pm

Postby Kate L. » Thu Aug 03, 2006 8:00 pm

Hi Alec,

yes - I am the allocated section editor.

Cheers

K
Kate L.
 
Posts: 5
Joined: Tue Apr 11, 2006 11:25 pm

Postby asmecher » Thu Aug 03, 2006 8:36 pm

Hi Kate,

It looks like you're running OJS 2.1.0-0 -- this is a known bug from that version that was corrected in OJS 2.1.0-1. The current release, OJS 2.1.1, is considerably newer and contains a number of additional bug fixes and new features. I'd suggest upgrading to OJS 2.1.1, but if you'd like a quick fix for this issue, I'd suggest asking your server admin to replace the file classes/submission/proofreader/ProofreaderAction.inc.php with the newer version at http://research2.csci.educ.ubc.ca/cgi-bin/cvsweb/~checkout~/ojs2/classes/submission/proofreader/ProofreaderAction.inc.php?rev=1.38;content-type=application%2Fx-httpd-php.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9076
Joined: Wed Aug 10, 2005 12:56 pm

Postby Kate L. » Thu Aug 03, 2006 8:44 pm

Hi Alec, thanks for this. sorry my searches didnt find the error and I took up your time.

Cheers

Kate
Kate L.
 
Posts: 5
Joined: Tue Apr 11, 2006 11:25 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 7 guests