OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Failed Ajax request or invalid JSON returned

To discuss the technical development of the Open Monograph Press.

Moderators: jmacgreg, John

Forum rules
Developer Resources:

Git: You can access our public Git Repository here. Comprehensive Git usage instructions are available on the wiki.

Bugzilla: You can access our Bugzilla report tracker here.

Search: You can use our Google Custom Search to search across our main website, the support forum, and Bugzilla.

Questions and discussion are welcome.

Failed Ajax request or invalid JSON returned

Postby vlilloh » Tue Sep 18, 2012 10:07 am

Hi,

I've just installed OMP 1.0 beta. Currently, all works great, except for one thing.

When I click in Add publication format, I get the following error:
Attachments
error.png
error.png (61.95 KiB) Viewed 2035 times
vlilloh
 
Posts: 281
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Failed Ajax request or invalid JSON returned

Postby asmecher » Tue Sep 18, 2012 10:24 am

Hi Vicente,

Depending on how you have your error reporting configured, PHP might be spitting out an error message in the middle of a JSON response. Check your error logs; this kind of thing is also easier to debug if you can dump the contents of the response, but you might need something like Firebug for Firefox to do that. I believe you can also do it with Google Chrome Developer Tools.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8334
Joined: Wed Aug 10, 2005 12:56 pm

Re: Failed Ajax request or invalid JSON returned

Postby vlilloh » Tue Sep 18, 2012 10:50 am

Hi Alec,

Thanks for your response. Please, tell me how to get what you need with Google Chrome Developer Tools.
Last edited by vlilloh on Tue Sep 18, 2012 1:06 pm, edited 2 times in total.
vlilloh
 
Posts: 281
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Failed Ajax request or invalid JSON returned

Postby asmecher » Tue Sep 18, 2012 11:13 am

Hi Vicente,

Just trying this out for the first time myself, so bear with me --

  • In Chrome, click the wrench icon, then go to Tools > Developer Tools.
  • Click on Console, right-click in the blank pane, and turn on "Log XMLHttpRequests".
  • Try the action that's causing you trouble.
  • Go into the "Network" tab. Find the request that's giving you trouble (should be right at or near the bottom).
  • Click the request and you should be able to view its response contents. Hopefully you'll see an error message in there.
Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8334
Joined: Wed Aug 10, 2005 12:56 pm

Re: Failed Ajax request or invalid JSON returned

Postby vlilloh » Tue Sep 18, 2012 1:05 pm

Hi Alec,

I thank you for your patience and your clear explanations. You were very specific.

Below you can see the error message. I've solved creating 'temp' folder manually. Have I done well? I don't understand, the 'files' folder had 777 permissions.

Regards,
Vicente
Attachments
image.png
image.png (74.69 KiB) Viewed 2021 times
vlilloh
 
Posts: 281
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Failed Ajax request or invalid JSON returned

Postby asmecher » Tue Sep 18, 2012 2:00 pm

Hi Vicente,

Thanks for debugging. That's fine -- I've filed a fix at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=7923, but if you've manually created the directory that'll solve the problem too.

Note that 777 permissions probably aren't safe to use if you're on a shared server.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8334
Joined: Wed Aug 10, 2005 12:56 pm


Return to OMP Development

Who is online

Users browsing this forum: No registered users and 0 guests