OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



***Email problem***

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

***Email problem***

Postby ismetferdi » Fri Jun 08, 2012 7:33 am

Dear PKP Support Team,

We have trouble with email sending. We tried every tips which was provided on forum page by you or users. (comments off in email setting, tried writing PLAIN or LOGIN for smtp_auth, contacted with technical service :), etc.) But all didn't remedy. I send our system infos and php.ini email configuration. Please guide us. Soon we invite our authors for the conferences. But email system doesn't work. This is really a shame for us. We are waiting for your urgent support. Thank you much in advance.

Best Regards,

Ferdi

********************************
System Infos:
OCS Current version 2.3.3.1

Server Information
OS platform WINNT
PHP version 5.3.6
Apache version Not available
Database driver mysql
Database server version 5.5.13

*************************************
Here is our php.ini email settings
Code: Select all
[email]

        ; Use SMTP for sending mail instead of mail()
        smtp = On

        ; SMTP server settings
        smtp_server = mail.xxx.com
        smtp_port = 587

        ; Enable SMTP authentication
        ; Supported mechanisms: PLAIN, LOGIN, CRAM-MD5, and DIGEST-MD5
        smtp_auth = LOGIN
        smtp_username = MYusername
        smtp_password = MYpassword

        ; Allow envelope sender to be specified
        ; (may not be possible with some server configurations)
        allow_envelope_sender = Off
        ; Default envelope sender to use if none is specified elsewhere
        ;default_envelope_sender = xxxx

        ; Enable attachments in the various "Send Email" pages.
        ; (Disabling here will not disable attachments on features that
        ; require them, e.g. attachment-based reviews)
        enable_attachments = On

        ; Amount of time required between attempts to send non-editorial emails
        ; in seconds. This can be used to help prevent email relaying via OJS.
        time_between_emails = 3600

        ; Maximum number of recipients that can be included in a single email
        ; (either as To:, Cc:, or Bcc: addresses) for a non-priveleged user
        max_recipients = 10

        ; If enabled, email addresses must be validated before login is possible.
        require_validation = On

        ; Maximum number of days before an unvalidated account expires and is deleted
        validation_timeout = 14
ismetferdi
 
Posts: 1
Joined: Thu Jun 07, 2012 7:46 am

Re: ***Email problem***

Postby vaniafreitas » Mon Jul 16, 2012 9:59 am

Good afternoon, I would like to know how to configure email in OCS, because I configured the SMTP port = 587 but did not work, perhaps it is the version of php 5.2.17? I need help.
vaniafreitas
 
Posts: 1
Joined: Mon Jul 16, 2012 7:21 am

Re: ***Email problem***

Postby jmacgreg » Mon Jul 23, 2012 10:37 am

Hi vaniafreitas,

Why are you trying port 587? Is your server set up to use that port for SMTP? (Servers typically use port 25 for SMTP.) If you could provide us with more information on what your server is (eg. operating system and version) we might be able to provide more assistance. Additionally, you may find this FAQ entry helpful.

Ferdi, unfortunately our team doesn't have much experience with Windows servers. As with vaniafreitas above, you sure that the port number you specify is correct? You should also be able to contact the person or organization who administers your mail server to determine what you should use for your server's authentication type (LOGIN/AUTH/PLAIN/etc.), and what the password, if any, is. If you are using an external email server to send mail, you may find the following links helpful:

viewtopic.php?f=8&t=6282

viewtopic.php?f=8&t=4828

Cheers,
James
jmacgreg
 
Posts: 4181
Joined: Tue Feb 14, 2006 10:50 am


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests