OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Search: No Results

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Search: No Results

Postby incognito » Thu Jun 21, 2012 7:34 pm

Hi!

I face a problem where the system always return a no results response. Here is what I have done, I have created a conference using the latest installment of OCS and index my page in the appropriate section, and yet it returns no results.

I wonder if I should have re-configure in order to correctly search for any data.

thank you for your help!
incognito
 
Posts: 5
Joined: Thu Jun 21, 2012 7:01 pm

Re: Search: No Results

Postby asmecher » Fri Jun 22, 2012 6:13 am

Hi incognito,

Try running the search index rebuild tool:
Code: Select all
php tools/rebuildSearchIndex.php
Note that search results are cached, so if you've only just published content, it may not appear until the cache expires. You can reset the cache manally through the Site Administrator's interface.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7743
Joined: Wed Aug 10, 2005 12:56 pm

Re: Search: No Results

Postby incognito » Sun Jun 24, 2012 11:02 pm

Thank you for your quick reply!

I have just cleared the data with the clear data caches function on the Site Administration webpage. However, I was still not able to search the conference. For instance, I entered a word from the title in the search field, but it returns a no results again. Also, I wonder where I should run the command that you have suggested. Locally? Using the terminal(with mac)?

Thank you again for your great help!

INCO.
incognito
 
Posts: 5
Joined: Thu Jun 21, 2012 7:01 pm

Re: Search: No Results

Postby asmecher » Mon Jun 25, 2012 6:14 am

Hi INCO,

The command needs to be run on the server side via a terminal. Let me know if that fixes the problem. (Just to confirm, the content you're searching is published for reading by non-priveleged users, correct?)

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7743
Joined: Wed Aug 10, 2005 12:56 pm

Re: Search: No Results

Postby incognito » Mon Jun 25, 2012 10:34 pm

Hi!

I am not familiar with using commands. Can you explain me how can I execute this command with MAC? Oh, and yes, it is for any users who wish to find a conference using the sidebar navigation.

Thank you so much! :D

INCO.
incognito
 
Posts: 5
Joined: Thu Jun 21, 2012 7:01 pm

Re: Search: No Results

Postby asmecher » Tue Jun 26, 2012 7:14 am

Hi INCO,

You need to run this command on the terminal on the web server, so you'll need to connect to it via SSH (secure shell). If your host allows that, they should be able to provide instructions.

Once you're connected, go into the directory that contains OJS, and run:
Code: Select all
php tools/rebuildSearchIndex.php
Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 7743
Joined: Wed Aug 10, 2005 12:56 pm

Re: Search: No Results

Postby mendesrocha » Mon Aug 19, 2013 7:57 pm

Alec,

I got a problem while running the rebuildSearchIndex.php script on my OCS 2.3.5 under PHP 5.2.17.

Our OCS actually hosts 22 conferences and about 2000 papers. The script is probably not running properly due to server memory limits (I've already changed max_execution_time, max_input_time and memory_limit) but server still returns the 'broken pipe' error.

Reading upon the threads, I found your comment on Bugzilla about executing the command for a specific journal. Hence, I ask you if is it possible to run the command for a specific Conference? regarding our OCS case.

Best,
Renato

ps: sorry for cross-posting on Bugzilla.
mendesrocha
 
Posts: 160
Joined: Mon Nov 05, 2007 11:10 am
Location: Brazil


Return to OCS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests