OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Login problem

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Login problem

Postby exgalaxy » Thu Jun 14, 2012 11:57 am

Hi,

We just installed OJS and OCS for the conference site. (http://online.journalism.utexas.edu/ocs)
There is a login problem. After I try to log in, I'm referred back to the login page. I have checked this in several browsers and also cache setting and followed others' comments in this forum.
It is still the same result. Strangely, I could log in, rarely, though.

Do you have any idea about this?

Thanks in advance!
exgalaxy
 
Posts: 3
Joined: Thu Jun 14, 2012 10:58 am

Re: Login problem

Postby asmecher » Thu Jun 14, 2012 12:48 pm

Hi exgalaxy,

Have you tried turning off the session_check_ip option as per here and elsewhere?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8599
Joined: Wed Aug 10, 2005 12:56 pm

Re: Login problem

Postby waluyo » Fri Jun 15, 2012 5:38 am

Several users in a conference that I manage also complaining this problem (cannot login, always return to login page).
I am also really confused since I cannot reproduce the problem.
Now I have changed to
Code: Select all
session_check_ip = Off

I hope this will solve the login problem.

Regards, Waluyo
waluyo
 
Posts: 63
Joined: Wed Mar 14, 2012 4:46 pm
Location: UTHM - Malaysia

Re: Login problem

Postby exgalaxy » Fri Jun 15, 2012 10:05 am

Thanks for replying!
But, I already tried to change to the setting, session_check_ip = Off. It is still the same.
So, I wanna try to remove OCS/OJS and to clean install the systems, again. I'm just a novice of this.
Do you have any idea how to remove them and how to do a clean install?

Thanks, in advance!
exgalaxy
 
Posts: 3
Joined: Thu Jun 14, 2012 10:58 am

Re: Login problem

Postby asmecher » Fri Jun 15, 2012 10:26 am

Hi exgalaxy,

Two possibilities: 1) Are you using URL rewriting (e.g. to get the subdomain configuration working)? If so, the cookie used for maintaining sessions might be getting set with the wrong path. Check your browser for a cookie called OJSSID and see what the value for "path" is for it.
2) Is there anything in your error log? A buggy version of APC might cause this kind of behavior, but you should see a log entry to go with it.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8599
Joined: Wed Aug 10, 2005 12:56 pm

Re: Login problem

Postby exgalaxy » Wed Jun 20, 2012 10:55 am

I really appreciate your help!

Beyond the login problem, we also have one error message like:
"Fatal error: Class 'HookRegistry' not found in /www/cmsoj/ocs/lib/pkp/classes/db/DAO.inc.php on line 194"

Based on your comments, we did two things:
1. first, turned off older version of APC: then, there was no problem with both login and fatal error message.
2. installed new version of APC: then, we have the same problem as before.

Now, the version of APC and PHP is
APC Version 3.1.9
PHP Version 5.3.3

Could you let me know any helpful idea?
Thanks, in advance!!!
exgalaxy
 
Posts: 3
Joined: Thu Jun 14, 2012 10:58 am

Re: Login problem

Postby asmecher » Wed Jun 20, 2012 3:28 pm

Hi exgalaxy,

That bug is an error in APC and there's not much we can do from the OJS side. If a new release of APC doesn't work, you could consider running another optimizer like Zend Optimizer or XCache.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8599
Joined: Wed Aug 10, 2005 12:56 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 3 guests